From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Connection Lost -1073807194

Dear

 

All I have simple VI I am using to Transmit various different messages over a USB COM port (using FTDI chipset) to a device then carry out a subsequent RX.

 

Some messages do not result in a reply back from my device and in this case I do not experience a problem, however when I use a message (e.g. send a status request) that causes my device to give a reply I get the "Connection for the given session has been lost" error whilst attempting the RX.

 

My RX is achieved by using a using a VISA get property node to get the no. of received bytes and then feed this to a visa read. It seems the error occurs at the visa read. It seems inconsistent as occasionaly the error is not generated on the first TX & RX cycle, or during the first few.

 

Although I have read some similar posts on here concerning this there are a few gaps which I need to fill to help me resolve the problem. I am using LV 7.1 on winxp service pack 2.

 

1) How can I find out my version of VISA as i understand an out of date version could be the problem

2) I have tried the documented trick of using the VISA set I/O buffer size but am usure of what mask value should be used if it is failing on RX

 

Any help much appreciated.

0 Kudos
Message 1 of 10
(10,293 Views)

I am now using ft245rl chip as the usb controller.I faced a lot of problems wih communication initially.

 

Please go throught he following stes

 

  • There will be a function called vcp in the ftdi website.You need to download this to enable serial comminication.(VCP drivers)
  • there will be something called d2xx functions for lv 7.0.You need to download this to enable communication directly through their drivers.
  • First i will suggest you download d2xx function and try their loop back example.
  • Revert back if it works properly.

 

 

0 Kudos
Message 2 of 10
(10,284 Views)
Also what is the ftdi chip you are using?
0 Kudos
Message 3 of 10
(10,282 Views)

There is a Knowledge Base article on this error code, but it was for Win-2000.  Don't know if it applies to Win-XP..

 

http://digital.ni.com/public.nsf/3efedde4322fef19862567740067f3cc/862567530005f09f862569dd007da5f0?O...

The article mentions VISA 2.5 which is a rather old version.  Which VISA version are you using?

 

R

Message 4 of 10
(10,279 Views)

Muks

 

I am using the FT232BM.

 

 

0 Kudos
Message 5 of 10
(10,276 Views)

Muks

 

Is it neccessary to take the D2xx route to get round this problem? I am using the VCP drivers so that I can treat my device like a virtual com port.

 

This has worked well for me for ages when I have used the same FTDI device with an RS485 interface,

 

The only difference here is that I am using an IBIS interface which runs at a slower baud rate and has different data bit/stop/start/parity settings and a different electrical interface, I cants  why this would start generating these errors.

 

Can anyone inform me how ro acertain what version of VISA i have please.

 

Thanks

 

 

0 Kudos
Message 6 of 10
(10,269 Views)

Here are a couple of ways to verify which VISA version you have.

 

(Preferred):  If you have MAX (Measurement & Automation Explorer), simply open the program, expland the "software" tree and look at NI-VISA, the version number should appear in the box on the right.  In my case, I have VISA 4.2.

 

 

 

 

(not necessarily accurate):  START menu, All Programs, go into National Instruments> VISA > Documentation> NI-VISA Read ME

It will describe which VISA version you have..  Example, I get:

 

National Instruments NI-VISA™ Software for Windows, Version 4.2

Read Me First, July 2007

© 1995–2007 National Instruments Corporation. All rights reserved.

Message Edited by JoeLabView on 08-29-2008 01:03 PM
Message 7 of 10
(10,256 Views)

Hi ATE Man,

 

I hope your well.

 

I am looking into your issue.

 

Firstly, I would like to repeat the request to know what version of NI-VISA your using, on face value your issue seems to be in the driver layer.

 

I have been looking on the FTDI website and have found a link for LabVIEW examples (maybe try these incase its your code that is an issue). Also, you will need to use/install FTDI drivers also. 

 

Please response with an update/more information.

 

Regards,

Message Edited by Hillman on 09-01-2008 10:36 AM
Kind Regards
James Hillman
Applications Engineer 2008 to 2009 National Instruments UK & Ireland
Loughborough University UK - 2006 to 2011
Remember Kudos those who help! 😉
Message 8 of 10
(10,195 Views)

 Hi ATE Man,

 

I was just wondering how things were coming along with your application and I am just posting to check if everything went ok and whether the problem was resolved as I have not heard back from you.  If you have any further questions on this issue, please respond.

 

Regards, 

Kind Regards
James Hillman
Applications Engineer 2008 to 2009 National Instruments UK & Ireland
Loughborough University UK - 2006 to 2011
Remember Kudos those who help! 😉
Message 9 of 10
(10,131 Views)

I am currently using LabVIEW 2010 and TestStand 4.2 to test a series of UUTs.  The UUTs contain a FTDI FT232R chip to convert a USB bus into a serial COM port.  I am using VISA mapping to connect to the COM port, along with a windows registry edit to 'lock' the COM port locations on the test PC (preventing Windows7 from adding a new COM port for each new UUT tested).  So far, this part works fine.
 
After each test, I need to disconnect the first UUT then connect the next UUT.  The resource is found and mapped into the appropriate COM port location.  Unfortunately, when I re-run the test, the error message "-1073807194: VISA: (Hex 0xBFFF00A6) The connection for the given session has been lost."  The only way I have been able to continue testing is to exit and restart LabVIEW.  This test needs to be made fully automatic for production line purposes.
 
Is there a way in LabVIEW to re-acquire the VISA resources without having to exit and restart?  Do I have to use the d2xx drivers to talk to the FTDI chip instead of the VISA drivers?

0 Kudos
Message 10 of 10
(7,790 Views)