Showing results for 
Search instead for 
Did you mean: 

Code converted to Sub-vi doesn't function

Go to solution


I will relay what I had to do later this AM.  Just wanted to say you can stop your effort on this request.

0 Kudos
Message 11 of 13

Attached is the sub-vi that works now.  Never had this happen before.

The reads/writes to the Agilent supply take an inordinate time to complete.  I had to move the V and I indicators out of the sequence an wire a local read in the idle condition in order for the values to be displayed.


Now this is the embarrassing part:  it's highly likely that the supply was responding to the write commands all the time, and simply not enough time was given to read the values in the next loop iteration.  The supply front panel is not easily viewed from the pc.  It was probably going to voltage during all this headache but I never checked!!  

So much for 'assumptions'


Thanks all for your help and suggestions...and patience.


0 Kudos
Message 12 of 13
Accepted by topic author bonnerupc

@bonnerupc wrote:

Attached is the sub-vi that works now. 

I see no reason for the sequence structure because the execution order is fully determined by dataflow alone.


Why would you write the value of a terminal to itself via a local variable (right case)? Seems pretty pointless.

0 Kudos
Message 13 of 13