LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot access excel using activeX object in LabVIEW

Solved!
Go to solution

ooth described and linked the solution to my problem, maybe it's the same for you. 🙂

G# - Award winning reference based OOP for LV, for free! - Qestit VIPM GitHub

Qestit Systems
Certified-LabVIEW-Developer
0 Kudos
Message 11 of 18
(267 Views)

I tried this already and it didnt work as well. One important thing for me is excel is not present in C:\Program Files, it is actually present in C:\Program Files (x86). Can this be a problem. 

0 Kudos
Message 12 of 18
(250 Views)

I just understood that if excel is stored in C:\Program Files (x86) then it means it is the 32 bit version and if it is stored in C:\Program Files it is the 64 bit version. My labview is 64 bit. So can 64 bit labview open a 32 bit excel application. Is that the problem?

0 Kudos
Message 13 of 18
(244 Views)

For me I'm using LabVIEW 32 bit and it works with Excel 64 bit version. I'm not sure about the reverse but that could be the problem.

0 Kudos
Message 14 of 18
(225 Views)

@ooth wrote:

For me I'm using LabVIEW 32 bit and it works with Excel 64 bit version. I'm not sure about the reverse but that could be the problem.


In my experience it has to do with how Office was installed. The underlaying ActiveX Automation server is perfectly able to be invoked across bitness boundaries, since ActiveX supports transparent out of process invocation if the Automation server supports out of process operation. The Microsoft Office components are able to support that but don't always get registered in a way that tells ActiveX that they do so. Especially the standard "Click to Run" installer that is most often used to get Microsoft Office onto a system, seems to be guilty of "forgetting" the necessary registry settings. I have in the past several times been able to fix that by doing a Repair Install of the Microsoft Office components in the Application Control Panel.

Rolf Kalbermatter
My Blog
0 Kudos
Message 15 of 18
(219 Views)
Solution
Accepted by topic author govindsankar

My IT department has done both the repair install and then de installed and install again. And still it didnt work. Now I have asked IT department to install Excel 64 bit in my pc. Let see how it works after installing 64 bit. 

0 Kudos
Message 16 of 18
(217 Views)

@ooth wrote:

I'm not sure if this is your problem but it fixed my Excel VIs that did work but didn't when I tried to run them on a new PC.

 

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019KZNSA2&l=en-US


I've rarely had a problem with running 32-bit LabVIEW's Report Generation Toolkit and Microsoft Office (almost always, I thought, 64-bit).  Just to check, I tried to find the "bit-ness" of my current Office 365 installation at work -- no indication, that I can find, of whether it is 32-bit or 64-bit!  Yet the RGT runs just fine.  Maybe Office 365 is "a different animal"?

 

Bob Schor

0 Kudos
Message 17 of 18
(205 Views)

So my IT department uninstalled my excel and installed 64 bit excel and it worked. 

Message 18 of 18
(143 Views)