Showing results for 
Search instead for 
Did you mean: 

Can't open Labview VIs: missing niriosession.dll

I have LabVIEW 8.0, 2010, and 2014 installed on a Windows 7 32 bit computer. I ran the NI Update Service program recently, and installed some critical updates. However LabVIEW 2010 wouldn't open a project anymore due to incompatibility with daqmx and rio versions. So I attempted to uninstall the newer versions and reinstall compatible versions. However I'm still getting an error when I try and open VIs that call FPGA module functions. A google search for the dll referenced below doesn't return anything. I reinstalled LabVIEW 2010, but that didn't help. Any thoughts?



LabVIEW: LabVIEW.exe - System Error

The program can't start because niriosession.dll is missing from your computer. Try reinstalling the program to fix this problem.

0 Kudos
Message 1 of 9

Hi Dillon,


while you can install several LabVIEW versions in parallel you cannot install additional modules (like RT or FPGA) in parallel.

So the question is: do you try to use LV2010+RT+FPGA in parallel with LV2014+RT+FPGA? I guess this will not work for LV2010…


I would also recommend to install LV8+LV2010 on one computer and LV2014 on a different computer (or virtual machine) as in general drivers only support the most recent LabVIEW version and 3 version before that.

But see for yourself here or here!

Best regards,

using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 2 of 9

I'd expect the modules to work in parallel (and have used them as such).  But, the drivers can't be installed in parallel.  They likely installed a version that's too new for all of their options.  Although, there isn't a driver set that will work across all of those versions

0 Kudos
Message 3 of 9

I uninstalled ALL National Instruments software from the PC using the Windows control panel function. Then I reinstalled Labview 2010 with the rio and fpga modules. However, I'm still getting the same error message when I open a VI that calls FPGA sub VIs. Can someone attach this phantom "niriosession.dll" file and tell me where it goes? I'm not sure what else to do other than reformat the hard drive and start over.

0 Kudos
Message 4 of 9

Hi dillon,


couldn't find this DLL on my computer.


Would you mind to attach your VI? (Please include the project file as that is important for FPGA VIs…)

Best regards,

using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 5 of 9

The project is large and has other dependencies, so I removed most of the other files except for a few FPGA related ones which produce the error if I try to open them. If I open the project and attempt to open "" or "" in the FPGA folder, I get the error message attached. It comes up four times before the close vi will open and six times before the init vi will open. Then they show with broken arrows.


Download All
0 Kudos
Message 6 of 9

Hi dillon,


using LV2017 I can open your project and the "Init FPGA"/"Close FPGA" VIs without problems!

(LabVIEW only tells me I need to compile the FPGA VI.)


The best is: I don't even have (or need) that "niriosession.dll":


Edit: Found the DLL in the C:\Windows folder under C:\Windows\System32 and C:\Windows\SysWOW64 in two different versions. Both with version for LV2017, so its unlikely you can use them.


All I can suggest is: do a full de-install of all NI software (including RT and FPGA modules), then do a clean install in the correct order (LabVIEW, RT, FPGA, DAQmx)…


Best regards,

using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
0 Kudos
Message 7 of 9

Did you install the RIO drivers? 

Not just the RT module for LabVIEW, but also the RIO driver that is standalone. 

0 Kudos
Message 8 of 9

First, I did uninstall all NI software then reinstall the 2010 ECM suite software (includes realtime, fpga, etc) before my last post. No help there.


After reinstalling 2010, I had NI-RIO 3.6. I then installed NI-RIO 13.1.0 (13.1.1 is the newest version compatible with 2010) from a DVD that came with one of the PXI-7853R FPGA cards. Neither version solved the error.

0 Kudos
Message 9 of 9