LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Build error "WinMain is missing vi or c file"?

When trying to build an executable in LabView 8.0.1 for the Pocket PC PDA, I get the following Build Error "WinMain is a missing VI or C file" does anyone know how to correct this problem? I have used this software on my old PC until it crashed and I was forced to reload software to my replacement PC... Did I forget one or more of the installation steps?
0 Kudos
Message 1 of 7
(3,857 Views)
Hi,
 
It does seem as this is a fairly common error with PDA modules. Have you tried uninstalling then re-installing Labview PDA 8.0? This should correct any corruption in the original installation. Could you give some more information on what your application entails? For example, are you using tab controls or any array functions? (these are common causes of this particular error.
 
This link also gives some more information on the debugging of PDA modules.
 
Regards,
Mike W
Applications Engineer
National Instruments UK&Ireland
Message 2 of 7
(3,848 Views)

So, now I'm confused. The last response in this thread makes it sound as though there is no workaround for tab controls causing this build error on a PocketPC. Is that true, or should re-installing LabView PDA solve it? I've used a tab control in a PDA app I've written before with no problem.

 

Thanks!

0 Kudos
Message 3 of 7
(3,762 Views)
There are many things that can cause the build error.  There may have been something with a tab control that had caused it at one point, but you are correct that tab controls can be used on PDA apps.  I belive they were just wanting some more information to get a better picture of what was going on with the application in question.
Regards,

Jared Boothe
Staff Hardware Engineer
National Instruments
Message 4 of 7
(3,735 Views)

I am getting this error too on my PDA applicaiton LV 8.2.1 If in the build specification properties dialog I enable the "Enable debugging" feature, then I dont get the "WinMain ..."

 error.  What would be the reason for this ?

 

/soren 

0 Kudos
Message 5 of 7
(3,575 Views)

Hi Soren,

 

Could you try unchecking enable debugging and then checking the "Generate Serial Only" checkbox under Application Information to see if your error is resolved by compiling sequentialy.Here is a link to more information on "Generate Serial Only" checkbox. I think "enable debugging" may eliminate the error because of the way it compiles the vi in order to display the block diagram. Could you provide a simple vi that generates this error so that I could look at it closer? Thanks for any help you can provide.

 

National Instruments
RIO Embedded Hardware PSE

CompactRIO Developers Guide
Message 6 of 7
(3,554 Views)

Dear All,

 

I want to create a Windows Mobile 6 Device application in Lab View.

I want to insert a dll which is created in VC++  to the Lab View and i want to use those functions in Labview.

i attached the Snapshot of Error,.

 

ErrorSnap1.jpg

 

Please help me

 

Thank you

Sunil

0 Kudos
Message 7 of 7
(2,820 Views)