LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Analog Discovery 2 does not communicate with Labview

Hello all!
I've got a problem trying to connect my Analog Discovery 2 to LabView. I am trying to run the example VIs that come with the AD2 toolkit for Labview, but AD2 is not detected, does not initialize and i keep on getting the error shown in the screenshot attached. It's my first time working with this AD2 toolkit for Labview. From what i have read on the internet, everything should work just fine after installing the programs needed. 
I'm using Labview 2018 and Waveforms 2015 (had Waveforms 3 before but uninstalled it just to try if it works with 2015, but the problem is the same). NI MAX, AD2 toolkit and Waveforms toolkit for Labview are also installed. The device is detected by the computer, works as it should in Waveforms, but it is not detected in Labview and NI MAX.
Could it be some kind of compatibility issues between the versions of Labview and Waveforms that i am using? If not, what should i do?

Thanks a lot and wish you all a nice day!

0 Kudos
Message 1 of 4
(1,729 Views)

@anghel_m

 

After doing some research, it seems that your power supply for the AD2 is faulty. Try using a different USB cable or use a 5V power supply for the AD2. Here is a link that I found dealing with a similar issue of yours. 

 

https://forum.digilentinc.com/topic/35-analog-discovery-troubleshooting/

0 Kudos
Message 2 of 4
(1,680 Views)

Thanks for the reply, but it is still not working with Labview. The device is listed in Windows Device Manager and also in Waveforms. I have tried powering the device with a different usb cable and an auxiliary 5V power supply, but with no success. 
I don't know what else to try. I am intending to use it for an university project, but i was not able to make any progress yet.
If you have any other ideas, it'll be awesome. Thanks!

0 Kudos
Message 3 of 4
(1,655 Views)

Hi anghel_m

Did you ever get your Analog Discovery 2 to communicate with LabVIEW using the AD2 Toolkit?

I am experiencing the same error on initialization.

0 Kudos
Message 4 of 4
(1,605 Views)