LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

3D graph plot properties - cannot be changed

Hi all,

 

I still cannot change the plot properties of the 3D graph.  I open the Plot Properties tab up and it gets stuck on the first page.

 

This means that I cannot release any VIs which use the 3D graph - a big problem.

 

Has anyone else experience this?  What do you suggest to fix it.

 

Thanks,

 

Battler.

0 Kudos
Message 1 of 27
(5,367 Views)

Hey Battler,

 

What properties are you trying to change? Are you referring to right clicking on the front panel > properties?

Andy Chang
National Instruments
LabVIEW Control Design and Simulation
0 Kudos
Message 2 of 27
(5,351 Views)
 Cannot edit the Plot Properties.  I can open the Plot Properties dialog but the page is stuck on Graph and I cannot select other pages.  I attached an image to show the problem:

 

3D Graph Plot Properties Error.jpg

0 Kudos
Message 3 of 27
(5,338 Views)

Hey battler,

 

Does it only happen with 3D scatter plot or with all 3D plots? I might try doing a repair on LabVIEW.

Andy Chang
National Instruments
LabVIEW Control Design and Simulation
0 Kudos
Message 4 of 27
(5,324 Views)

Actually, currently only happens for a certain VI.

 

Have installed 2009 SP1.

0 Kudos
Message 5 of 27
(5,302 Views)

Hi battler.,

 

So if you open a new VI and drop down a 3D Graph, you can successfully open the Plot Properties? Perhaps your original VI or that instance of the 3D Graph on your original VI.

 

Aaron P

National Instruments

Applications Engineer

http://www.ni.com/support

0 Kudos
Message 6 of 27
(5,282 Views)

one year later...

 

I'm seeing this same problem.  I drop a new 3d scatter into a new vi and can't see anything but the first page of the 3d plot properties dialog.

 

If I close the project and open the vi on its own, the pages work fine.  I have another VI in the project that has a 3D scatter in it that worked until I added the second one.  Removing the first one from the project did not make a difference. I searched and found no recently modified files in vi.lib.

 

behavior is identical on two computers, both running LV2010sp1.

-Barrett
CLD
0 Kudos
Message 7 of 27
(4,981 Views)

It is weird that I can not reproduce the problem both on LV2009SP1 and LV2010SP1(Evaluation). What I did is 1) launch LV, 2) click the "Blank VI" from the Getting Started, 3) drop a Scatter and open its "3D Properties", 4) click the Category and the content on the right changes.

 

Can you give a detail steps how you encounter the problem? Also can you try using the keyboard Up/Down to move the Category index after mouse click?

0 Kudos
Message 8 of 27
(4,970 Views)

I have experienced exactly the same behavior (can not change 3D graph plot properties) with 3D plots (scatter and surface) in LabVIEW 2011.  The 3D plot properties page works correctly at first but then fails to switch pages after larger data sets have been loaded to the graph.  For example, my scatter graph contains 13 plots, each with 320 points of data.  Once the page "gets stuck" it is stuck for all 3D graphs until the offending graph is deleted and re-created.  To reproduce this issue create at least one 3D plot with a large number of plots in it.

 

On a related note, if there was a programmatic method for deleting plots from a 3D graph then it's possible that this issue could be worked around.

Message 9 of 27
(4,908 Views)

Hi njg,

 

Do you use the LV2011 English version? I tested with 100 plots and 3600 points for each plot. The page does not get stuck, though changing any property reacts slowly. Actually, I modified the example scatter plot with a for loop. Can you attach your test VI to reproduce problem?

 

Thanks,

0 Kudos
Message 10 of 27
(4,897 Views)