Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

changing port in NIMAX for a Network connected device

Hi all 

 

I am having a Keithely 2460 which is connected via ethernet cable and is having a fixed IP. In NIMAX, under Netwowrk device i am able to see the device. But under settings, when i try to change the port number, i am getting the following error message. ( see attached image) 

 

" There was a problem saving the settings for the device, Could not access the resource". 

 

But i can access the device and  use the web user interface via the IP Address. 

And if i click "Open Visa Test panel", i get the error: "Error opening resource: VISA: ( Hex 0xBFFF0011) insufficient location information or the device or resource is not present in the system" 

 

Anyone have any idea about this problem. 

 

I am having NIMAX 19.5.0f0

 

Thanks in advance 

 

 

Nghtcwrlr

---------------------------------------------------------------------------------------------
*************************************
---------------------------------------------------------------------------------------------
0 Kudos
Message 1 of 2
(827 Views)

Hi,


I'm looking into what could cause the problem. I know you might have tried some or all of these basic troubleshooting steps/questions, but do you mind confirming and/or trying the following:
1. Try to ping the device through cmd (open cmd and type "ping x.x.x.x" where x.x.x.x is the IP address of your device.
2. Do you have NI VISA installed?
3. Do you have the driver necessary native LabVIEW driver for the device installed?

There's a high probably that it could be either a connection issue, that's mainly why I'd like to confirm these steps. I want to make sure it's not that before we can move on to finding other possible solutions.

Cheers

0 Kudos
Message 2 of 2
(755 Views)