Instrument Control (GPIB, Serial, VISA, IVI)

cancel
Showing results for 
Search instead for 
Did you mean: 

NI Max Showing Unconnected devices

Solved!
Go to solution
Highlighted

Hello,

 

I am still quite new to the labview community but was running into some issues within NI MAX. I am using a Agilent 82357B USB-GPIB connector to communicate with my different instruments. Usually the communication works just fine. The issue I am running into is NI MAX is showing me connections that aren't currently connected. The screenshot below is with no devices connected.

Eugene93_1-1598385173097.png

 This can cause NI MAX to time out when opening along with causing it to be very slow. Is there any way to remove these items? I have tried looking on some other threads, using Tools -> reset configuration data, repairing NI-Max using the NI Package Manager, uninstalling NI-MAX and reinstalling it with a new VISA driver install. I am running NI-MAX as Administrator. As a side note I did have to turn on NiVisaTulip.dll. Running NI-Visa 20.0, any help would be appreciated 

0 Kudos
Message 1 of 6
(593 Views)
Highlighted

HI,

 

maybe try removing VISA aliases?

0 Kudos
Message 2 of 6
(553 Views)
Highlighted

I tried removing the Alias but there there were none to be cleared. All items still show up on the resource list.

Eugene93_0-1598465297241.png

 

0 Kudos
Message 3 of 6
(527 Views)
Highlighted

Hi,

 

Have you also tried deleting visaconf.ini ? The steps are also in the link.
Delete VISAConfig.PNG

 

If you haven't delete it, maybe you can share the visaconf.ini before and after delete so that I can have a look into it.

0 Kudos
Message 4 of 6
(516 Views)
Highlighted
Solution
Accepted by topic author Eugene93

I think you must have Keysight Visa (I/O Libraries) installed as well? I know it returns devices that it has previuosly seen but are now offline.

 

If so then you can go into MAX and the Visa Conflict Manager and disable Keysight VISA or uninstall it.

 

If not then just try disabling the tulip passport and see if the GPIB1::* go a way

Message 5 of 6
(506 Views)
Highlighted

I uninstalled the Keysight IO library and reinstalled it and the issue has been resolved. Thanks for the suggestions!

0 Kudos
Message 6 of 6
(459 Views)