Industrial Communications

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem connecting a cRIO as an EtherCAT master with a third-party EtherCAT slave

Hi,

 

I’m trying to use a cRIO-9038 as an EtherCAT master that connects with a third-part EtherCAT slave. However, the cRIO cannot seem to discover the slave device. It seems to be this exact problem, but the solutions there haven’t worked.

 

The slave device is the Ingenia Jupiter 20/80 EtherCAT Servo Drive (product manual). No C Series modules are being used to interface with it. An EtherCAT cord connects the second port of the cRIO to the Jupiter board. The Jupiter board is powered up and working correctly, with all the latest firmware installed.

 

The LabVIEW Real-Time software is the only software used (no SoftMotion or VeriStand). NI-Industrial Communications for EtherCAT 20.0 is being used. A new project was set up according to this NI document (with special emphasis on the section titled, “Adding Third-Party EtherCAT Slaves to NI Master Controllers” because the NI 9144 was not used). XML/ESI files were downloaded from the link at the top of this download page (version 2.7.8) and imported as described in the NI document. The entire folder of XML files was imported.

 

Some of the files gave the following error message when they were attempted to be imported:

cberg22_0-1623332625358.png

 

 

One of these problem files is named “DriveDict_0x10142.xml.” Since the 10142 is the slave device we’re connecting to, that could be a problem. 

 

As stated in this document (same as the first link), the XML files have been moved to the C:\Program Files (x86)\National Instruments\LabVIEW XXX\resource\Framework\Providers\indcomecat\DD directory. LabVIEW still says it cannot find the slave device. The error message and setup is shown below:

cberg22_1-1623332625361.png

 

 

If I click “New target or device” instead, the correct device shows up:

cberg22_2-1623332625359.png

 

 

When it’s added, variables show up in the Project Explorer:

cberg22_3-1623332625356.png

 

 

However, I can use this method to add other devices (NI 9144) that are definitely not connected to the cRIO. That makes me think that the XML files are there, but the cRIO cannot establish communication with the Jupiter board. Additionally, the Link LED on the Jupiter board that would light up to indicate an established link has never been lit. 

 

I’m at a loss, so any help is greatly appreciated.

0 Kudos
Message 1 of 5
(1,782 Views)

Hi there,

 

I have the same problem using another slave (ELMO Platinum). I can’t import properly the slave under the ECAT LV master neither open the ECAT bus. I was able to import and handle the previous version of the driver and  I discovered that the new one is declared as MDP in its ESI/XML. I have found a NI topic which require to import the “parents profile” and “device profile” in order to import and run the MDP ECAT slave. Therefore I didn’t understand who play the role of parents profile and device profile because I have only one XML (provided by ELMO) where I personalized the TxPDO and RxPDO respectively (I added the required address and the Sm tag…). Which kind of file is the MDP “parents profile”? Could anyone add some further details about MDP Slave and NI ECAT master?


Any further clarification from NI will be really appreciated and maybe useful for both slaves type in this topic.

 

Thanks,

Best,

F. 

0 Kudos
Message 2 of 5
(1,629 Views)

I know this is a very old post, but I was wondering if there was any resolution? It sounds very similar to a problem I'm having with a Control Techniques M751 motor drive not being recognized despite installing the ESI files

0 Kudos
Message 3 of 5
(637 Views)

Thanks, but I have already tried that. This system is connected to 6 other 3rd party slaves (from other vendors), which all are identified without issue.

0 Kudos
Message 5 of 5
(620 Views)