Hobbyist Toolkit

Showing results for 
Search instead for 
Did you mean: 

I can't open the Firmware Wizard.

Go to solution

Hi. I have a problem. I tried to use the Firmware Wizard, but I get this message.


What am I doing wrong? I have the LabVIEW version 21.0.1 and I installed from the VI Package Manager the package Digilent LINX (Control Arduino, Raspberry Pi, BeagleBone and more) version I tried to fix through the button option "Wizard Settings", and I pushed on the button "Generate", and then it showed the window with the message "Done".

2022-05-26 (1).png

But when I tried open the Firmware Wizard again, I get the same error that I mentioned above. Please help me with this. Thanks and sorry for my English.

0 Kudos
Message 1 of 6

Just to confirm you are not using the LabVIEW Community Edition, correct?


If you are using the Community Edition then you don't need to install anything from VI package manager as LINX is included with the Community Edition and installing the package may have messed up what is installed with the Community Edition.


If you are using a non-Community Edition of LabVIEW then you do need to install LINX manually but it sounds like the package you installed is the old Digilent package which only works with LabVIEW 2016.


Please provide more information on your setup and I can point you in the right direction.

David Wilt
The New Standard LLC
0 Kudos
Message 2 of 6

I downloaded "ni-labview-2021-community-x86_21.1.0_offline", so I installed the LabVIEW Community. What I should to do? Could I uninstall the Diligent LINX and try to open Firmware Wizard again or uninstall the LabVIEW Community and reinstall all again? Thank you for the help.

0 Kudos
Message 3 of 6
Accepted by topic author JorgeMR

I would uninstall all of LabVIEW as others have not been able to fix it in this situation.

David Wilt
The New Standard LLC
Message 4 of 6

Thanks. In fact, I uninstalled the Digilent LINX and tried to open the Firmware Wizard again, but it showed the same error. I will uninstall all of LabVIEW and reinstall it. Regards. 

0 Kudos
Message 5 of 6

I reinstalled all of LabVIEW and now I can open the Firmware Wizard. The message "Something went wrong. Please try running this wizard again. If the problem persists please check the wizard settings or post on the LVH LINX Forums at: www.labviewmakerhub.com/forums/linx File/Directory Info in Check Path.vi->Read PNG File.vi->LMH-LINX.lvlib:Load Device Image.vi->LMH-LINX.lvlib:Firmware Wizard.vi<APPEND> Builds:\LINX.png" don't show now. Thanks for the help.

0 Kudos
Message 6 of 6