Hobbyist Toolkit

cancel
Showing results for 
Search instead for 
Did you mean: 

Hobbyist Tool Kit Install LabVIEW 2021, Target Configuration.vi Newer than LabVIEW 2021 wont run!

I have a frustrating problem, I want to start working with Raspberry Pi's in my full developers version of LabVIEW 2021 which as of this post had been updated with NI Package Manager and NI Update SErvice to be all up to date. However from the initial Tools > Hobbyist > Configure Target it fails to run with the following error.

 

Dave_Button_0-1641990921505.png

 

As mentioned everything else appears to be up to date....I have tried removing and re-installing Hobbyist Tool Kit with zero luck, restarting in between etc.

 

Dave_Button_1-1641990988407.png

 

Dave_Button_2-1641991005866.png

 

Please any thoughts or help appreciated!

 

Dave

 

 

 

 

  

0 Kudos
Message 1 of 11
(256 Views)

You seem to run LabVIEW 2021 Beta, and not the release version. LabVIEW Beta can NOT open release version files despite being the same basic version.

 

Check what your LabVIEW About Dialog shows. If it says 21.0b10 then something is not right. You likely will need to deinstall it completely and reinstall the release version that you can download here.

Rolf Kalbermatter
Averna BV
0 Kudos
Message 2 of 11
(238 Views)

You were correct, for some reason it didn’t update 2021 64bit from the beta version.

 

anyway I did a complete removal and reinstall and it appeared to fix the initial problem.

 

however now I have a new issue, it appears that the SSH communication through the target configuration tool appear to not run.

 

I have been trying all manner of things to fix this, but currently having no luck.

0 Kudos
Message 3 of 11
(181 Views)

Hi Dave,

It could be same problem that people are having with LabVIEW 2021 community edition. Here is a link to the forum topic

 

https://forums.ni.com/t5/Hobbyist-Toolkit/Labview-CE-2020-connects-to-raspberry-but-CE-2021-does-not...

 

The Hobbyist toolkit is supported on 32 bit versions of LabVIEW.

 

0 Kudos
Message 4 of 11
(176 Views)

The more I seem to dig into it there appears there is an issue with the .NET constructor for the SSH session.  Probing the SSH Open.vi it appears the constructor not isn't really linked to the DLL that it should be.  Unfortunately I can't seem to find the correct DLL to point at.

 

Cheers,

 

David

 

Kind of frustrating as I was hoping this would all work out of the box.  The other thread appears just to run the install process on the Raspberry Pi manually. 

0 Kudos
Message 5 of 11
(164 Views)

@Dave_Button wrote:

You were correct, for some reason it didn’t update 2021 64bit from the beta version.


I don't believe that the Hobbyist Tool Kit is compatible with 64-bit.  If you look at the Community Edition, which includes the Hobbyist Tool Kit, it only comes in 32-bit.  Also, if you look at this thread, https://forums.ni.com/t5/Hobbyist-Toolkit/LINX-blink-example-error-5003-using-Arduino-Uno-Rev-2/td-p... we also came up with a 64-bit issue.

 

I would try 32-bit and see if that resolves your issue.

David Wilt
The New Standard LLC
0 Kudos
Message 6 of 11
(153 Views)

I actually fully removed the 64 bit addition and left it as the 32 bit on reinstallation.  Maybe there were some legacy bits left behind.

 

either way I might be able to solve the issue if I could find out what the DLL the Open SSH.vi etc is meant to be using as this is where the constructor node appears to not be editable as it has lost the reference to the associated DLL.

 

0 Kudos
Message 7 of 11
(137 Views)

If you are not using the Community Edition then you should be able to uninstall and reinstall the Hobbyist Tool Kit through VIPM to fix any linking issue which may have been caused be uninstalling LabVIEW 64-bit.  I have never had good luck getting this to work with LabVIEW when uninstalling versions.  That is why I always start with a fresh install of Windows when switching versions.

 

Good Luck.

David Wilt
The New Standard LLC
0 Kudos
Message 8 of 11
(131 Views)

I have done the uninstall and reinstall so many times now. I have tried both the Hobbyist Toolkit and the LINX individually as also together.  I just can get any of them to resolve the issue.

 

I have followed through the preparation of the Raspberry Pi 4 manually and it is a working target now. How frustrating though I so so excited about this capability being included in LabVIEW, but every time in the past and even now with the 2021 addition it had never once been a smooth process. There is always something not lining up that needs repair etc.

 

maybe NI should just release a image for the Raspberry Pi already configured with its bits ready to go.

0 Kudos
Message 9 of 11
(126 Views)

@Dave_Button wrote:

 

maybe NI should just release a image for the Raspberry Pi already configured with its bits ready to go.


That's not how Linux normally works and the Raspi is in essence still a Linux tool too. Linux may sound like it is one monolithic and static system but the reality could not be further from the truth. It is an ever moving target with every new version, and in terms of distributions often even a totally different system.

 

And while Microsoft made Windows a moving target too in recent years they still have a large base that has been kept consistent since the inception for Windows 95 and NT 3.5 thanks to a holy cow of Microsoft until a few years ago, called backwards compatibility. Linux never had that "problem" as many Linux developers are quick to abandon an old technology, sometimes because it doesn't fit the modern requirements, sometimes simply because of a personal vendetta, where one of the developers doesn't like an idea of another developer.

Rolf Kalbermatter
Averna BV
0 Kudos
Message 10 of 11
(113 Views)