FieldPoint Family

cancel
Showing results for 
Search instead for 
Did you mean: 

FP TC 120 returns 0.000000

Hi

i recently have been having some problems with FP TC 120 modules.  This system controls a process that reads a pressure value and a temperature from the TC 120. I'm finding suddenly over the last couple of weeks that the module appears to be returning 0.000000 instead of actual data intermittetanly. no errors are reported, it just returns 0.000000 instead of valid data

he is a sample of data recorded

time               date          voltage       pressure     temperature

4:27:49 PM , 6/8/2007 , 1.000000 , 0.035570 , 524.428040
4:27:51 PM , 6/8/2007 , 1.000000 , 0.035570 , 524.365784
4:27:53 PM , 6/8/2007 , 1.000000 , 0.035555 , 524.334656
4:27:55 PM , 6/8/2007 , 1.000000 , 0.035540 , 524.303528
4:27:57 PM , 6/8/2007 , 1.000000 , 0.035537 , 524.272400
4:27:59 PM , 6/8/2007 , 1.000000 , 0.035537 , 524.241272
4:28:01 PM , 6/8/2007 , 1.000000 , 0.035531 , 524.179016
4:28:03 PM , 6/8/2007 , 1.000000 , 0.035518 , 524.116760
4:28:05 PM , 6/8/2007 , 1.000000 , 0.035503 , 524.116760
4:28:07 PM , 6/8/2007 , 1.000000 , 0.035488 , 524.085632
4:28:09 PM , 6/8/2007 , 1.000000 , 0.000000 , 0.000000
4:28:11 PM , 6/8/2007 , 1.010000 , 0.000000 , 0.000000
4:28:13 PM , 6/8/2007 , 1.020000 , 0.000000 , 0.000000
4:28:15 PM , 6/8/2007 , 1.030000 , 0.000000 , 0.000000
4:28:17 PM , 6/8/2007 , 1.040000 , 0.000000 , 0.000000
4:28:19 PM , 6/8/2007 , 1.050000 , 0.000000 , 0.000000
4:28:21 PM , 6/8/2007 , 1.060000 , 0.000000 , 0.000000
4:28:23 PM , 6/8/2007 , 1.070000 , 0.000000 , 0.000000
4:28:25 PM , 6/8/2007 , 1.080000 , 0.000000 , 0.000000
4:28:27 PM , 6/8/2007 , 1.090000 , 0.000000 , 0.000000
4:28:29 PM , 6/8/2007 , 1.100000 , 0.000000 , 0.000000
4:28:31 PM , 6/8/2007 , 1.110000 , 0.000000 , 0.000000
4:28:33 PM , 6/8/2007 , 1.120000 , 0.000000 , 0.000000
4:28:35 PM , 6/8/2007 , 1.130000 , 0.000000 , 0.000000
4:28:37 PM , 6/8/2007 , 1.140000 , 0.000000 , 0.000000
4:28:39 PM , 6/8/2007 , 1.150000 , 0.000000 , 0.000000
4:28:41 PM , 6/8/2007 , 1.160000 , 0.000000 , 0.000000
4:28:43 PM , 6/8/2007 , 1.170000 , 0.000000 , 0.000000
4:28:45 PM , 6/8/2007 , 1.180000 , 0.000000 , 0.000000
4:28:47 PM , 6/8/2007 , 1.190000 , 0.000000 , 0.000000
4:28:49 PM , 6/8/2007 , 1.200000 , 0.000000 , 0.000000
4:28:51 PM , 6/8/2007 , 1.210000 , 0.000000 , 0.000000
4:28:53 PM , 6/8/2007 , 1.220000 , 0.000000 , 0.000000
4:28:55 PM , 6/8/2007 , 1.230000 , 0.000000 , 0.000000
4:28:57 PM , 6/8/2007 , 1.240000 , 0.000000 , 0.000000
4:28:59 PM , 6/8/2007 , 1.250000 , 0.000000 , 0.000000
4:29:01 PM , 6/8/2007 , 1.260000 , 0.000000 , 0.000000
4:29:03 PM , 6/8/2007 , 1.270000 , 0.000000 , 0.000000
4:29:05 PM , 6/8/2007 , 1.280000 , 0.000000 , 0.000000
4:29:07 PM , 6/8/2007 , 1.290000 , 0.000000 , 0.000000
4:29:09 PM , 6/8/2007 , 1.300000 , 0.000000 , 0.000000
4:29:11 PM , 6/8/2007 , 1.310000 , 0.035430 , 522.498047
4:29:13 PM , 6/8/2007 , 1.310000 , 0.035409 , 522.466919
4:29:15 PM , 6/8/2007 , 1.310000 , 0.035409 , 522.435791
4:29:17 PM , 6/8/2007 , 1.310000 , 0.035457 , 522.342407
4:29:19 PM , 6/8/2007 , 1.310000 , 0.035476 , 522.280151

you can see from this data that at 4:28:09  we started getting  0.000000  and it continued for exactly 1 minute until 4:29:09, then the data appears to return to normal

This, unfortunately destroyed a $50k high power microwave amplifier during processing.  I am on the hot seat here as you might expect. I am in the process of modifying the code to trap these 0.000000 readings, but I need to know what is causing this problem. Is it the FP-TC 120 or possibly the controller that is running the modules? (FP 1601)

thanks for any input.
0 Kudos
Message 1 of 5
(5,098 Views)

It looks like you also lost your pressure reading as well.  Can you describe overall system and all the hardware involved.

0 Kudos
Message 2 of 5
(5,091 Views)
Hi

the system uses the following modules

FP 1601 controller
FP-TC-120    - monitor pressures and temperatures
FP-RLY-420  - control bakeout ovens on/off
FP-AO-210  - provides drive voltage for external power supply
FP-TC-120 - monitor pressures and temperatures
FP-RLY-420 - control bakeout ovens on/off

this system monitors and controls upto 8 discrete bakeout stations, all mechanically identical

This system has been operational for almost 5 years wihtout any major problems. No changes have been made to the hardware or software in the system for almost 3 years.

I'm thinking this is an intermittant fault in either a controller or the FP-TC module given the hardware and software has been static for 3 years
I have already swapped out the suspect FP-TC modules in the hopes of solving the problems. i have also modified the code to alert me if/when the 0.000000s start to appear again.

i dunno if this is the informatino you are looking for or not, but I appreciate the reponse. Thanks/






0 Kudos
Message 3 of 5
(5,091 Views)

I think you are on the right track by modifying your code so that system safely handles the loss of readings.  Since you have already swapped out TC modules, them I'd guess that you are looking at either an input transient/condition that upsets TC modules or a problem with the interface module.  Input condition could also be caused damaged wiring to sensors or even a sensor failing.

Does this problem seem to happen to certain channels on the TC modules or does an entire module read zero's at same time?

0 Kudos
Message 4 of 5
(5,083 Views)
Hi

Well it took a little work to correlate the data, made more difficult by the fact that all the stations are not operational all the time, but yes, to answer your question, it appears when the 0s appear it is module wide, all channels seem to go to zero

Since replacing the tc-120 modules, we have successfully operated several process with no 0 errors. It's still early days but I'm hopeful this has solved the problem, but a much longer test is required before i will have confidence in the system again

thanks again for your input


0 Kudos
Message 5 of 5
(5,076 Views)