FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

roboRIO Firmware Update woes

Go to solution

I tried to update the firmware on one of our RoboRIOs tonight, but the FRC roboRIO Imaging Tool crashed partway through the Update Firmware process.  (See attachment showing the information from the Windows Error Reporting entry in the Windows Event Log.)

The RoboRIO shows up still in the tool, but it shows a current firmware version of "unknown".  Subsequent attempts to flash firmware fail.

I've tried:

  • Flashing the v6 firmware (roboRIO_6.0.0.cfg) through the 2019 FRC RoboRIO Imaging Tool with the robot:
    • In regular mode
    • In safe mode
  • Flashing the v5 firmware through the 2019 FRC RoboRIO Imaging Tool in regular mode.
  • Flashing the v5 and v6 firmware through the (current 2018 image) Silverlight Web Dashboard.
  • Flashing the v6 firmware using the NI MAX tool.


I've tried flashing the v6 firmware using 2 different computers.  They were plugged into the RoboRIO using the USB cable, running with other network adapters disabled, were running the tools as Admin, and had the Firewall and antivirus disabled.  The roboRIO doesn't have any error conditions indicated by the LEDs or shown in the Web Dashboard.


The typical error message is below:

Imaging Failure.png


Any ideas?  I was able to flash firmware on a different RoboRIO without any issue.  Does this RoboRIO need to be replaced?





Will Rall

FRC Team 1318 - Issaquah Robotics Society

0 Kudos
Message 1 of 12

Hello wrall,


From what I see in the Imaging Tool, it is possible that the crash had corrupted the installation of the firmware in the roboRIO. I recommend the following:


  1. Try going through the steps in this document: 2019 FRC Firmware Update Failing
  2. Give us a call from 1 to 7 PM CST (weekdays) so we can troubleshoot with you.



0 Kudos
Message 2 of 12

Hi Oscar,


I have tried going through those steps, as well as the suggestions posted here as of Thursday evening:


Unfortunately I don't have access to the RoboRIO during those hours on weekdays.  I could still call to arrange a return/replacement if that is needed, or take the retry that evening and call back the next day approach.




0 Kudos
Message 3 of 12

Hello Will,


I recommend we try getting in contact by phone with the support team, so they can understand better the behavior you are seeing in the different components (thanks for the super detailed first post you made), and can send more steps and resources to try.


If the device is indeed "bricked", we would process the repair by phone, too. I recommend you get the Serial Number of the device (located in the bottom side of the roboRIO in a white label) in case we need to follow that route.



0 Kudos
Message 4 of 12

On further inspection, if I try to switch the roboRIO into Safe Mode (by holding the "Reset" button for ~5 seconds after the RoboRIO has booted), the Status light flashes incessantly.  I assume that this is an indication that the RoboRIO needs to be returned.  I'll have someone call NI in the next couple days to set up a return.



-Will Rall

0 Kudos
Message 5 of 12

Hello Will,


It does not necessarily mean that the roboRIO has to be returned, but that its software got corrupted. Please mention this when you get in contact with us by phone, so we can try recovering the software in your roboRIO before you have to ship it.


Thank you!

0 Kudos
Message 6 of 12
Accepted by topic author wrall

To update the thread: I called support and was able to resolve the issue with their help.  They provided a special version of the firmware that I put onto a USB stick, and then I restarted the RoboRIO with the USB stick plugged in while holding the RESET button.  This triggered it to flash the firmware on the USB stick.  I was then able to flash the newest version of the Firmware, and the RoboRIO is now working perfectly.

0 Kudos
Message 7 of 12

Hello, I have the same issue trying to flash a roborio to setup a bench top robot for our FRC team.  Tried different computers, safemode, etc, as suggested in this thread. Ready to try the USB boot. How can I get hold of this special image? (I could not locate NI support phone number).  Thank you for your help. 

0 Kudos
Message 8 of 12

Please find the NI support number for FIRST here:Connect with NI FRC Technical Support.


If you're outside the United States, you can call into the NI's local line for your location and ask to be transferred to the FIRST Support queue.



0 Kudos
Message 9 of 12

Thank you for the reply.   Also noticed the phone number on the bottom of the the page (and every page on NI web site ... ).  Update:  Contacted support and received a link to the recovery image. Tks again

0 Kudos
Message 10 of 12