From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

Using RAD on the RoboRIO

We're trying to use RAD to capture an image from the RoboRIO and seeing an error consistently.


Pasted image at 2018_05_22 06_52 PM.png


What's the best way to get additional support on this from NI?


The image is not the stock team image.  It is modified with all of the tools and utilities and our code running on it.  RAD does work to capture the stock team image but that doesn't help me capture this image.

0 Kudos
Message 1 of 13

The best way currently is to keep posting here as the support line is closed during the off season.


Past that my first suggestion is to try using one of the example projects to so we can see if this error persists in source code as well and see if that error gives us a better idea of what is happening.


To get to the example projects do the following:


1) Open LabVIEW and go to Help > Find Examples...

2) The NI Example Finder will open and then you can go to Hardware Input and Output > System Configuration > Get and Set Real-time Images

3) Try running the example to get an image (since it basically does the same thing as RAD) and see if you get similar error

4) Post back on the errors that you get and post back the specific VI that is throwing the error since now you have the source code and block diagram to debug


Application Engineer, RF and Communications
National Instruments
Message 2 of 13

Thanks!  Will do and post back with results.

0 Kudos
Message 3 of 13

I ran the example but the error is no less cryptic (same error in fact).  It did lead me to a KB that instructed me to use MAX to update the firmware on the RoboRIO - I did do that.  The firmware was updated from 3.0.0 to 5.something (there might have been a letter in there) but the error persisted.


It reboots the RoboRIO and starts it in SafeMode and then it dies after copying some files.


Picking apart the example and looking for details, it seems like the example uses a DLL to run the capture process and it is dying inside of that DLL with no additional details.  Any other ideas or things I can try?  Is it possible for me to open a ticket and get support?

0 Kudos
Message 4 of 13

Weird - I had a response and it appears to have vanished so I apologize if this ends up posted twice.


Ran the test using the example.  It did not resolve the issue and resulted in the same error message. It did lead to a article about updating the firmware on the RoboRIO using NI MAX.  Proceeded to update it from 3.0.0 to 5.0.something (not sure what the something was, don't have the machine open at the moment).  After the update, the same error was observed with both the RAD tool and the example VI.


Poking at the VI revealed a DLL that is throwing the error.  The DLL seems to be a bit of blackbox and I'm not sure what else to poke at here.  Suggestions are welcome.  I really would like to be able to resolve this though so we can make a complete system image.

0 Kudos
Message 5 of 13

That's weird. If it's a DLL maybe part of the driver on the computer is installer improperly. Either way my thoughts are to try to reinstall the driver that has this DLL which I think is NI System Configuration.


NI System Configuration 17.0 -


Otherwise, you could probably use this article to get to your ultimate goal of backing up the RIO.


How Can I Back Up My Real-Time System? -

Application Engineer, RF and Communications
National Instruments
0 Kudos
Message 6 of 13

Yeah... it's not a driver issue.  A DLL is just a library on windows.  In this case, it's something NI wrote that is making all the calls to actually perform the backup operation.  Go open up the example and you'll see it.  It's just a bit of blackbox code that eventually throws the error I pasted.  It doesn't seem to provide any real logging that would be useful unfortunately.


That article is where I started this journey.  I'm now stuck and need assistance.

0 Kudos
Message 7 of 13

Try clonezillia in the meantime which is another option on the article.


Past that If you're talking about a DLL inside of the VI as I highlight below, the that DLL would be installed by the system config driver and so doing a reinstall of that would be the best way to test if the issue persists between clean installs.





Application Engineer, RF and Communications
National Instruments
0 Kudos
Message 8 of 13

So I truly don't think that's the issue as we've run into this on two separate Windows systems on two separate laptops that were each installed independently of each other (not using the same install media).  That doesn't rule out an issue with the FIRST LabView install mind you.


Clonezilla has the caveat so I don't believe it will work on the RoboRIO - "Clonezilla Live is a free third party disk cloning utility that can be run from a USB flash drive, a CD or a DVD.  This utility will only run on PXI targets and Real-Time Desktop systems.  This will not work for cRIO, sbRIO, WSN 9792 and Real-Time FieldPoint devices. For the most up to date instructions on using Clonezilla Live refer to the Clonezilla live doc page on Clonezilla's webpage."


I'm open to more suggestions though.  Not trying to say I've got all the answers but it's frustrating not knowing what this thing is doing behind the scenes so I can debug further.

0 Kudos
Message 9 of 13

What steps are you taking to get the roboRIO you're working with to the current state?  (Are you just installing the team image, sending your startup executable, and installing a few FRC based tools?  Or, are you doing something more interesting than this?)


I'm mostly curious as to what is taking place on the FPGA and if you're even able to see the FPGA with your software stack.

0 Kudos
Message 10 of 13