FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem after installing SP1 update

I installed the SP1 updates when they came out, and now when I attempt to deploy the code, I receive an error in the vision processing.

Errors are listed in this post http://forums.ni.com/t5/LabVIEW/nivissvc-dll-Error/td-p/3104722

I uninstalled all of the National Instrument  software and started again.

Installed Labview from the DVD.

When applying the FRC Update, I am receiving the following message:

Procedure Entry Point Gen_MarkExternalBufferNoThreadCore could not be locating in the dynamic link library nivissvc.dll.

It will also pop up when I am loading RobotMain.vi.  I do not have a robot to test with at the moment, as we have the St Louis Regional tomorrow.  I can build the project, but I do not know if it will deploy or not.  Has anyone seen this error before, any help would be appreciated.

0 Kudos
Message 1 of 20
(7,608 Views)

Don't install the SP1 update.  It's ok to install the "critical" updates.   Avoid the optional updates.  The SP1 version of the vision software isn't  compatible with your base LabVIEW version.  If you install that, it'll break  your project.

Is that the newest version of the FRC Update Suite?

0 Kudos
Message 2 of 20
(3,158 Views)

That is where the problem is.  The SP1 has already been applied.

The SP1 update was installed before I saw any warnings, and now I am trying to restore to before the SP1 was applied.

I uninstalled all of the current National Instruments software on the PC. 

I then loaded Labview from the DVD, and applied the FRC Update Suite 1.0.  The error first showed when I was loading the FRC Update Suite 1.0.  Now, it shows up every time I open RobotMain.vi.

My guess would be that an updated (SP1) version of the nivissys.dll file isn't being removed during the Uninstall process.

Is there a location for the .dll file so that it can be replaced from a machine with a version of FRC Labview that hasn't had the SP1 applied previously?  I tried the one under National Instruements/RT Images/Common.../1.14.0.

0 Kudos
Message 3 of 20
(3,158 Views)

Try installing everything from the command prompt.  Go to your start menu and type cmd into search and run that.

If you haven't worked with the command prompt before, cd.. let's you go up a directory.  dir displays what is in the current directory.  cd [name] changes to a new directory(folder).  You'll want to navigate to the folder where you have the installer.  Once you get there, type: setup.exe /reinstall

Do this for both the LabVIEW and FRC Update Suite installers.

0 Kudos
Message 4 of 20
(3,158 Views)

Setup.exe does not take /reinstall as an option based upon the option list that pops up.

Sent from my iPhone

0 Kudos
Message 5 of 20
(3,158 Views)

If it's giving you that much of a hard time, it'll be quicker to uninstall everything and install the non SP1 version.  There's no reason the setup.exe shouldn't have taken the /reinstall flag.

0 Kudos
Message 6 of 20
(3,158 Views)

The setup.exe /reinstall was not working because it was the suite install setup.exe I was attempting to use it on.

I uninstalled all National Instrument software.

I ran setup.exe /reinstall to put the software back on the PC.

I ran it for :

Labview

Labview Real Time

NI Vision

NI Rio

FRC Simulation

NIIMAQ.

I then applied the FRC software using the setup.exe /reinstall

Labview Update

Driver Station

FRC Utilities

FRC Gamepad.

After all of this, I am still receiving the error when attempting to open RobotMain.vi. I tried it both on an existing project, and a newly created project.

Would there be a log somewhere on the PC that would show where the error is being generated? Is there anything else that could be done to correct this?

0 Kudos
Message 7 of 20
(3,158 Views)

At that point, what's the error/warning dialog it's giving you?

0 Kudos
Message 8 of 20
(3,158 Views)

A pop up box that reads:

The procedure entry point Gen_MarkExternalBufferNoThreadCore could be located in the dynamic link library nivissvc.dll.

This happens when opening RobotMain.vi.

0 Kudos
Message 9 of 20
(3,158 Views)

Is it possible to post a screenshot of what you see in NI License Manager?  You can find that in your Start Menu.  Expand as many trees as you can and post the screenshot?

0 Kudos
Message 10 of 20
(3,158 Views)