FIRST Robotics Competition Discussions

cancel
Showing results for 
Search instead for 
Did you mean: 

FRC imaging tool can't assign IP address to cRio II

When I run the imaging tool it fails with the error "unabel to assign an IP address forthe CompactRIO device. Ensure the IP Reset switch on the CompactRIP device is turned off." The screen shot also shows that none of soft switches are asserted. I have tried multiple resets and re-runs of the tool but it always fails. The Imaging tool version is 2013.1.10.

cRioIT.png

0 Kudos
Message 1 of 3
(5,767 Views)

Your imaging tool version is the lastest - that's good.  Things I can think to try (in order) are:

  1. Turn off the Windows Firewall.
  2. In the TCP/IPv4 Properties click the Advanced button and make sure you don't have extra IP addresses configured.
  3. Try setting your computer to 10.18.68.6 in case there is a conflict with a Driver Station at dot 5.
  4. If your wireless is enabled, try disabling it.
  5. If you are directly wired to the cRIO, try going through a switch.
  6. Next to last resort you can hold down the cRIO reset button for 5 seconds to put it into SAFE mode and try from there.
  7. Last resort - can you try configuring from another computer?
0 Kudos
Message 2 of 3
(3,129 Views)

Hi Doug,

I turned off the Norton SmartFirewall, removed one extra IP address and set the IP to 10.18.68.6. With those changes I was able to successfully image the cRio. Sorry I don't know which one of those fixed the problem but thanks for the help.

Phil

0 Kudos
Message 3 of 3
(3,129 Views)