FIRST Robotics Competition Discussions

Showing results for 
Search instead for 
Did you mean: 

Driver Station loosing communication with robot randomly on Windows 10

On Windows 10, the Driver Station (v19 from ) keeps loosing communication with the robot, error code 44004.  It does this when using wifi, direct cable to the router, or USB to the RoboRio.  I have created a empty timed robot template in c++ and loaded it on two different robots and get the same result with both. I have loaded FRCUpdateSuite_2019.2.0 on Windows 7 and I do not get the same results. The Driver Station does not loose communications with the robot. On Windows 10, Firewall is disabled for Domain, Public, and Private Networks. For each of the 3 methods of connecting to the robot, the network is set to private. 

0 Kudos
Message 1 of 2

At one time I had similar symptoms due to an issues with mDNS on our win 10 PC.  I solved it by installing Apple Bonjour.  The screen step below notes that NI mDNS Responder Installed with the NI FRC Update Suite is as well as Apple Bonjour are common mDNS implementations for windows.   For some reason my PC mDNS just worked better with Bonjour.


I was able to detect that it was an mDNS issue by doing pings with roboRIO-xxxx-FRC.local.   It would work for awhile then stop working.  I could always ping with successfully with xxx.xx.xx.xx (depending on the connection) but it would loose the mDNS connect.


Give it a try, it might help

0 Kudos
Message 2 of 2