Digital Multimeters (DMMs) and Precision DC Sources

cancel
Showing results for 
Search instead for 
Did you mean: 

Fluke 8846A multimeter Error: 488.2 interrupted query [-410], Connection: LabView <-> 2xLAN <-> 2xFluke

Issue: We use two Fluke 8846A multimeters in the testbench. There appears "Error" on the display of both multimeterss and a loss of communication, reading values from multimeters via TCPIP to Labview. For example after 10min after start of Labview. Manual control using the buttons on the multimeters is functional. I can see the error in Fluke Menu > System> Error> 488.2 interrupted query [-410]. Power cycle of the multimeters will help to clear the error, but the error will reappear in about 10 minutes. 

 

Fluke Report: I asked Fluke about this Error: " The -410 Interrupted Query error is caused by asking the 8846A for something (querying it) and then querying it again without reading the first response. This is not the fault of the 8846A but of the commands being sent to it. You will need to troubleshoot the Labview driver with NI directly to find the fault with the command sequence in the Labview driver. "

Testbench is controlled from Labview. Testbench includes NI chassis cDAQ 9181 (9476, 9203, 9263, 9472, 9474), 9184 (9263,9474), 9188 (9205, 9263, 9401, 9472), Modbus equipment, Switches, AC/DC power supplies via TCPIP.

What can be the reason of Fluke error? Combination of control and measuring throught many NI chassis, also throught Modbus and TCPIP? Delay of query with Fluke? We think about to try Keysight 34461A multimeters instead of Fluke 8846A. Thank you for any ideas.

0 Kudos
Message 1 of 4
(533 Views)

All this information you have provided points out that the program developed in LabVIEW is causing the trouble (and not LabVIEW - the programming language itself). Please share the source code of the automation that interacts with your DMM.

Santhosh
Soliton Technologies

New to the forum? Please read community guidelines and how to ask smart questions

Only two ways to appreciate someone who spent their free time to reply/answer your question - give them Kudos or mark their reply as the answer/solution.

Finding it hard to source NI hardware? Try NI Trading Post
0 Kudos
Message 2 of 4
(505 Views)

Thank you for trying to help and to look for the reason of issue between Labview - NI - Fluke. 

I uploaded here:

1] Some PrintScreens in png from our test program from DMM modules regarding to DMM Fluke control:

DMM_program overview, DMMStartupSubpanel, DMM2SignalBufferFgv, DMM_Main_Multi_Read. 

 

2] Zipped test program - full directory with DMM modules. Zip file includes all files from LabVIEW\Modules\TcpIp\DMM.

 

3] Log that could includes some data about Fluke Error: There are logged some issues with other module named GAM. Sometimes there appears also secondary issue on Labview control panel. SW Buttons start to be frozen or untouchable. Data reading and hw control is with delay 4-8 sec. LView restart solves it.

" 2022-04-26 13:58:28.161 ERROR 63 GAM - WriteOutputRegisters.vi: : Error 63 occurred at TCP Open Connection in IOManagerWriteOutputRegisters.vi->IOManager.vi->IOManagerRWLoop.vi->Main.vi; ; Possible reason(s): ; LabVIEW: Serial port receive buffer overflow. "

 

4] Fluke - part of manual in txt file about communication: 8846A Remote Operation - How the Meter Processes Input - includes interesting note:

" Attempt has been made to read data from the Meter's output buffer when no output is present or pending. Possibly a new command line has been received before a previous query has been read or both input and output buffers are full."

 

I would like to mention that I am not a Labview programmer. SW is written externally. It is still in progress to find the reason of Fluke Errors and also of random program freezing. If we dissable Fluke in SW, we have already detected that freezing still appears. So it seem the issue is more complex due to communication with HW throught NI chassis, Modbus ,TCP/IP. I sent this topic in forum also to our external programmer.

0 Kudos
Message 3 of 4
(475 Views)

Update: Fluke Error issue is still opened, in progress.  

I uploaded one most important part from Labview program with this description received from ext. programmer:

This VI is called from Timed Loop with period of 100ms and with discards missed periods, maintain original phase and with following parameters: miliseconds to wait = 0 and timeout ms = 5000. Connection stays opened for next loops.

 

Here is also link for used Fluke driver:

Home>>Support>>Downloads>>Drivers>>3rd Party Instrument Drivers>>Fluke 8846A > 

http://sine.ni.com/apps/utf8/niid_web_display.model_page?p_model_id=9431

 

0 Kudos
Message 4 of 4
(399 Views)