Digital I/O

cancel
Showing results for 
Search instead for 
Did you mean: 

Why does USB-6509 not allow setting input and output on individual ports?

Solved!
Go to solution
I have one of the new USB-6509 boards (96 channel digital I/O).  This has 12 ports each with 8 bits.  The manual says you can set them to be input and output on a port by port basis.  When I read from one 8 bit port I find that it will clear different ports that I have set up to be digital output.  They seem to be grouped together in 3 groups of 4.  0-3,  4-7, and 8-11.  When I read from any single port from within that group it clears the other ports in that group that I am trying to use as outputs.  The result is that I can only set input and outputs in groups of 4 ports.  Unfortunately we built custom hardware based on the assumption that we could control input and output on a port by port basis.  I see this problem both with my LabVIEW 7.1 program (see attached) as well as with the Measurement and Automation Explorer.  Has anyone out there seen this problem with the USB-6509?  Anyone using it successfully?  I also notice strange problems with power on but I havent figured out the pattern yet.  Im wondering if I have a defective hardware or maybe this new hardware still has issues.  I have tried NIDAQ 8.7.1 and 8.8.  Same problem with both. Thanks.
0 Kudos
Message 1 of 4
(3,094 Views)

Andy,

 

First off I would like to welcome you to the NI forums and thank you for posting your issue. 

 

I have been playing with a USB-6509 and the program that you posted. If I understand the issue that you are having correctly you have tried to connect Port 0 to Port 1 where Port 0 is your Digital Output and Port 1 is your Digital Input and when you try to use the program that you attached the digital output that you are trying to read will clear the digital input port that you are trying to write to. Is this correct? I was able to connect Port 0 to Port 1 and use Port 0 as an ouput and then read the data from Port 1 using your program. 

 

I want to make sure I am understanding the problem correctly. 

 

 

Aaron W.
National Instruments
CLA, CTA and CPI
Message 2 of 4
(3,066 Views)

Hello,

 

I struggled a little with the port settings of USB-6509, but I was able to set single ports as outputs  or inputs (not single lines, as I tried in the beginning). In particular I use the following:

P0, P9 and P11 out

P1, P2, P5 in.

 

I attach the task definition file for it.

 

 

0 Kudos
Message 3 of 4
(2,990 Views)
Solution
Accepted by topic author andylikescandy
Thanks for the responses.  It has been determined that the USB-6509 that we have has a hardware malfunction that is causing the ports to interfere with each other.  We are sending it back to NI for repair or replacement.  For now we used a PCI-DIO-96 which is working properly. Thanks, Andy
0 Kudos
Message 4 of 4
(2,982 Views)