Developer Center Discussions

Showing results for 
Search instead for 
Did you mean: 

Add-on name is not listed in the Third Party Add-on window


I am from DigiMetrix (ex ImagingLab) company, we make and cell LabVIEW Add-ons for industrial robot arms control, and use the licensing from SoftwareKey and Third Party Licensing and Activation Toolkit.

We have never experienced such problems, but recently two customers reported that our Add-on does not show up in "Third Party Add-on" window (we could not yet reproduce this problem).

This behavior was observed on :


1) Win10 Pro 64-bit, LabVIEW 2017.0 32-bit, With Denso Robotics Library 

2) Win7 64bit SP1, LabVIEW 2017 (17.0f2 - 32bit) and Win7 64bit SP1, LabVIEW 2015 (15.0.1f10 - 32bit) with KUKA Robotics Library


At all cases we checked that

- installation in VI Package Manager was made with Administrative rights (KUKA library also has an automatic check of administrative right presence during installation).

- Addon components are installed properly in the National Instruments folder

- License file installed properly in the specified folder

- No errors reported by VI Package Manager


At both cases there are missing items in  respective \Company\Product\ subtrees of registry tree in

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\National Instruments\LabVIEW\17.0\PartnerAddons\... 

We also tried (at case 2) to run RegisterAddon.exe manually:

1) Run cmd.exe as administrator
2) cd "C:\Program Files (x86)\National Instruments\LabVIEW 2017\resource\Partners"
3) RegisterAddon.exe -- -s -l "vi.lib\DigiMetrix\Kuka Robotics Library\Kuka Robotics Library.lvlib"


And that did not help.


Any suggestions and ideas are highly appreciated!

If somewhere can be found information on command-line parameters for RegisterAddon.exe - it is also highly appreciated!


Best Regards,

Svetlana Volkova

0 Kudos
Message 1 of 6

Hi Svetlana,


Is this one customer or multiple customers who have experienced this issue?

Have you been able to reproduce the problem at your site? If so, what are the steps?



Matt J - NI Tools Network
0 Kudos
Message 2 of 6

Hi Matt,

It is two customers within one week:

1) One with Denso library, Win10 64-bit + LV17 32-bit

2) Another with KUKA library, he tried on few computers (the issue appeared on two of three computers) - Win7 64-bit + LV17 32-bit, Win7 64-bit + LV15 32-bit

We could not reproduce the issue, which makes it a bit complicated to debug. 

Also, one of the customers has sent us the LabVIEW startup log where is phrase ( I can send you the full version)

"LV2P - Checking digital signature for Software Key Dll. Error code: SoftwareKey Protection PLUS DLL (KEYLIB32.DLL) is invalid

LV2P - Add-on not loaded, library: <library path>"


"LV2P - Checking digital signature for Software Key Dll. Error code: SoftwareKey Protection PLUS DLL (KEYLIB32.DLL) is invalid
Bad License! The unlicensed library is: [ 1380075852 "DensoRoboticsLibrary.lvlib [LVContext "Main Application Instance" (0x05a94370)]"]"

Do you know anything about that?



0 Kudos
Message 3 of 6

Hi Svetlana,


Can you please provide the full log file, and can we move this discussion to Basecamp?



Matt J - NI Tools Network
0 Kudos
Message 4 of 6

Hi Matt,

Sorry for the delay - I just got back to office.

Sure lets move this conversation to Basecamp. Will you create this conversation or I should do it?

The log is attached. If you tell me how to create this log - I will ask the scond customer with similar problem to create one.



0 Kudos
Message 5 of 6



I have some further insides to this problem.


We just recently had the same problem with 2 customer PCs running Windows 7 Pro and LabVIEW 2018 SP1 32bit.


I've tried the same suggestions as above, alas with no success.


Then I also created the extended LabVIEW startup logfile as suggested in this thread.

Comparing that to a logfile on a VM where everything went smooth I realized that one line is missing.


The Logfile should contain these two lines:

LV2P - Checking digital signature for Software Key Dll. Error code: SoftwareKey Protection PLUS DLL (KEYLIB32.DLL) is invalid
LV2P - Checking digital signature for Software Key Dll. Error code: SoftwareKey Automation DLL (SKCA32.DLL) is invalid

But on the machine where the toolkits were missing, the line about SKCA32.DLL is missing, just like in the upload above.


We had one hint what might be wrong, since also the "NI Update service" and the "NI License manager" could not connect to Also a lot of calls to websites were refused with "certificate errors".


After some lengthy discussion with the network administrator of the provider of the PCs we found out that the PC image was not up-to-date and had quite a few "root certificates" missing. The network admin also had deactivated the updates of those certificates (side-note: these PCs are only used in an internal network that is not connected to the internet).


Well, after an update of all "root certificates", finally everything is working. Toolkits show up in the "third-party window", NI update service and license manager do work.


Regards, and I hope it helps if someone might run into the same problem.

Kudos are welcome...
0 Kudos
Message 6 of 6