Continuous Integration

cancel
Showing results for 
Search instead for 
Did you mean: 

Jenkins stalling on VIPM VIs

Solved!
Go to solution

Hey everyone,

 

I've been able to mass compile, and build PPLs and Executables via a batch file that Jenkins is running when I commit. However, when I try to run a VI containing the VIPM API, Jenkins stalls indefinitely (>15 minutes).

 

The strange thing is, when I run the batch file directly on the Build Machine (by double clicking on the batch file in the Jenkins workspace) the Windows command prompt runs through the script and everything works merrily (<4 minutes).

 

I've noticed that when I run the batch file directly, LabVIEW opens the front panels of all the VIs that run and the LV Search box appears briefly. Also, VIPM seems to be doing stuff. However, VIPM seems to do nothing when Jenkins runs the batch file.

 

Can anyone think of a reason why the batch file stalls when Jenkins runs it, but not when you run the batch file directly?

It only seems to be VIs that contain the VIPM API, when I comment out those steps, the rest of the script runs as expected.

 

(I'm using G-CLI now, but I got identical behaviour when I was using the Native LabVIEW CLI)

0 Kudos
Message 1 of 6
(1,362 Views)

Hi Tom,

 

back in the days (sounds like Ben 😉 when I was experimenting with CI, I saw similar behaviour. I was able to trace it down to user account/ license trouble when trying to run the stuff automatically. This resulted in Message Boxes, which remained unanswered...

 

Maybe this could be a hint.

 

Cheers

Oli

Thanks for supporting the GLA Summit 2021!

GLA Summit 2021
Message 2 of 6
(1,356 Views)

Hi Tom 

 

I faced similar issues due to licensing as Jenkins ran under windows service instead of my own windows account. And our NI volume license / network license is associated with individual’s windows account. It worked for me when I ran Jenkins right under my account using the following command

 

java -jar "C:\Program Files (x86)\Jenkins\jenkins.war" --httpPort=[your desired available port number].

 

 Thanks

 AJ 

0 Kudos
Message 3 of 6
(1,343 Views)
Solution
Accepted by topic author McQuillan

Dear Tom and Ajay,

 

If you want to use a different user (I think I also had this problem - my Jenkins server runs as my local login, rather than system), you can configure this at the service level by opening the services page (Computer Management > Services and Applications > Services) and then going to the Login tab of the Properties for the Jenkins server (i.e. via right-click menu).

 

There you can set whichever user and password you need. In my case, it's my employer-issued user account, together with @oist.jp, but your login methods may vary!


GCentral
0 Kudos
Message 4 of 6
(1,331 Views)

Thanks everyone, you're a bunch of legends!

 

As you all mentioned, it appears to be a licencing issue.

 

Like Christian said, I changed the login details for the Jenkins service and now the VIPM API VIs are running! WOO! (I'm still getting errors... but different errors, so progress is being made!)

 

McQuillan_0-1604051068353.png

 

0 Kudos
Message 5 of 6
(1,318 Views)

For the agents running on the build nodes of GitLab (gitlab-runner) and Azure DevOps (agent), we'd always execute them not as a service but interactively - i.e. in a PowerShell windows. That way, we always see what's happening (and sometimes what's not happening).

 

Just an FYI for if/when you arrive at the point where you want to migrate Jenkins to a distributed build architecture with dedicated build nodes.


DSH Pragmatic Software Development Workshops (Fab, Steve, Brian and me)
Release Automation Tools for LabVIEW (CI/CD integration with LabVIEW)
DQMH® (The Future of Team-Based LabVIEW Development)

0 Kudos
Message 6 of 6
(1,286 Views)