Showing results for 
Search instead for 
Did you mean: 

Replication and Deployment Utility (RAD)

Hi cgibson,


That feature isn't currently part of the imaging in System Configuration or RAD (though we are actively tracking requests for it). The workarounds we've generally recommended is to set the programming modes during Real-Time application startup or prior to pushing an image (I think it persists through the image and doesn't reset but don't quote me on that). This KB has example VIs for programmatically setting the value via the System Configuration API. 

Charlie J.
National Instruments
Message 321 of 324

I did some testing on a dev system and imaging via RAD seemed to have no affect on the setting no matter what it starts as. I only tested DAQmx and LabVIEW settings, but my guess is that it would persist no matter the setting.


From our viewpoint, this is a bug. We used a working system to create a image that would be distributed to production sites. Those distributed images did not work once on site.


Thanks for the link! I had been trying to write this but had missed some steps. The example in the link set me straight.

0 Kudos
Message 322 of 324

Has anyone had a problem where RAD doesn't ask for the Password of the sbRIO and eventually times out?  I think it might be a network setting since we're connecting to the sbRIO through an EWON with Ecatcher.  One of my colleagues was able to connect a while back when the first set things up but all the other times we've tried it keeps timing out, we've tried connecting from different sites and different computers.  If we have someone Local try it works just fine.  So my only thought is one of the ports got closed or a setting on the network was changed through the EWON so does anyone know what port might of been closed or had a similar problem?

0 Kudos
Message 323 of 324



I analyze the comportment of RAD when it create Image on target and I see that a volume is mounted at this directory: /mnt/userfs/ and the Image is created here. Is it possible to mount the volume on external USB key or other external memory? Maybe someone know where the path of the mounted volume is configured ?

I tried to change this path to solve the issue when the target doesn't have enought space to host its Image





Message 324 of 324