NI Home > Community > NI Discussion Forums

Switch Hardware and Software

Reply
Member
Confustus
Posts: 5
0 Kudos
Accepted Solution

Switch Soft Front Panel, Active Device misassigned

I have a PXI chassis with, among other modules, two PXI-2350 switches.  Using the Switch Soft Front Panel, it seems the names assigned in the Active Device list ( the two 2350's in this case ) are backwards to what I expect.  Is there a way to reassociate these names to the physical 2350's ?

 

Thanks

Member
Frank-L
Posts: 160
0 Kudos

Re: Switch Soft Front Panel, Active Device misassigned

Confustus,

 

Can you better explain your question on the problems that you are seeing with you 2530 modules? You can identify and rename the devices in Measurement and Automation Explorer (MAX) to better suit your needs. 

 

 

Frank,
National Instruments
Staff Software Project Engineer
Member
Confustus
Posts: 5
0 Kudos

Re: Switch Soft Front Panel, Active Device misassigned

Under MAX ( Measurement and Automation Explorer ), the names are correct and we have many test sequences that expect the names as presented in MAX.  Thus, our test sequences are able to properly access the 2350's.

 

The problem is when we're using the Switch Soft Front Panel ( for experimentation ), the names in the list are backwards.  Now, that's not a huge issue as long as everyone's aware of it, but it is nonetheless incorrect and confusing to a newcomer.

 

Because MAX has the proper assignment and the Soft Front Panel does not, it suggests that MAX and Soft Front Panel do not use the same "name-to-module" configuration.  The question then is, how can the names be reconfigured for the Soft Front Panel only.  Is there a config or ini file somewhere that Switch Soft Front Panel uses to make this association ?

Member
Frank-L
Posts: 160
0 Kudos

Re: Switch Soft Front Panel, Active Device misaligned

Confustus,

 

The NI SWITCH Soft front panel pulls the names of the devices in Measurement and Automation explorer and organizes the names of the devices alphabetically. In max, these devices are organized by their position in the PXI Chassis, however the names should be the same.  For example, in the image below you will see a snippet of the devices that I have simulated in max and are placed in the order they were created (or for a real device, in the slot number of the chassis). However, the soft front panel organization is slightly different and is based on the alphabetized name of the device.

 

Picture.png

 

Is this what you are seeing? If so renaming the devices in max alphabetically will allow the representation in max and the soft front panel to be identical. Since this might break current teststand functionality, I would leave it as is since the order does not affect operation of the devices.

 

If this is not what you are seeing, can you provide screenshots??

 

Frank,
National Instruments
Staff Software Project Engineer
Member
Confustus
Posts: 5
0 Kudos

Re: Switch Soft Front Panel, Active Device misaligned

So, if I understand your pictures, our Soft Front Panel should be accessing our two different switch modules using the same names as MAX.  What's troubling, however, is that Soft Front Panel is somehow selecting the wrong 2530 module.  We verified this by routing a power source through the switch then over to a 4071 DMM.

 

Using MAX, we can select a route that connects the power source to the DMM using "Switch 1" ( for example ), and we can see the voltage reading show up on the 4071 Soft Front Panel as expected.  If, however, we use the Switch Soft Front Panel and make the same connection using "Switch 1", we read nothing on the DMM.  If we instead select "Switch 2" and connect the route ( which SHOULD be the incorrect 2530 module ), then the connection is made.  It's as if the Switch Soft Front Panel is getting the two devices mixed up ... as if the way it associates the Active Device to a physical device in the PXI chassis is somehow out of whack.

 

From what your previous post stated, however, both MAX and the Soft Front Panel should be using the same name-to-device association.  We're not seeing that.

Member
Frank-L
Posts: 160
0 Kudos

Re: Switch Soft Front Panel, Active Device misaligned

Confustus,

 

That is an interesting issue that I have never seen before, your devices in Soft Front Panel should be linked to the devices as labeled in MAX. I was wondering, when you say "Using MAX, we can select a route that connects the power source to the DMM using "Switch 1" ( for example ), and we can see the voltage reading show up on the 4071 Soft Front Panel as expected", what exactly do you mean? If you were to select your hardware device and click test panels, the NI Switch Soft Front Panel loads. Are you saying that when selecting test panels and loading Switch Soft Front Panel from max works as expected, however opening the application outside of MAX does not work? 

 

Or are you talking about the Test Panels that you open up within NI Switch Executive? The test panels for NI Switch Executive refer to the NI Switch Executive virtual device name, not the DAQmx device name. If you had named the NI Switch Executive Virtual device name in a similar manner, this could be part of the confusing problems that you are seeing. See images below:

 

NI DAQmx Device Name.png

NI DAQmx Test Panel Selection Brings this up.

 

NISE Device Name.png

NI Switch Executive test panel brings this up. If these device names are similar, I can see how this could be confusing.

Frank,
National Instruments
Staff Software Project Engineer
Member
Confustus
Posts: 5
0 Kudos

Re: Switch Soft Front Panel, Active Device misaligned

[ Edited ]

Thanks for the explanations Frank.  Due to being a bit new to this, I admittedly don't understand it real well and as such I've mangled some of the explanations.  A colleague who does understand our setup, however, read your replies and he said your post above explains what we're seeing.  Thanks for the time you put into this.