Showing results for 
Search instead for 
Did you mean: 

"Resetting vi" and program lock-up

I have a wierd problem.  When I run the program on a desktop system (P4 2.8G w/ 1G ram and Labview run-time engine 8.2.1), I have 50% chance getting the "Resetting vi" message on the screen and program lock-up.  While I run the same program from my laptop (Core 2 Dual 2.0G w/ 2G ram and Labview professional development system 8.2.1), this never happen.  I checked the device drivers' version from MAX, they are all the same.   Both systems run Windows XP w/ SP2.  Any ideas or suggestions?  Thanks.
0 Kudos
Message 1 of 2
Hi dodo99,

Does the "Resetting VI" message happen when the program terminates?  In that case, please see this KnowledgeBase: What Does the "Resetting VI: (VI name)" Message Mean in LabVIEW?

If you are not terminating the VI and you are still getting the "Resetting VI" message, it is likely related to the way the code was written.  You mention that the desktop only has the Run-Time engine, I'm assuming this means you're running an executable on both machines.  Do you have access to the code?  If so, you can check the performance and memory usage of your code in LabVIEW by going to Tools » Profile » Performance and Memory.  Also, it may be helpful to check if the code follows the LabVIEW Style Guide. If this does not work, then please post a screenshot of your code so we can better determine if there is a problem with the programming.

I hope this helps!

Erik J.

Message 2 of 2