VXI and VME

cancel
Showing results for 
Search instead for 
Did you mean: 

How do I stop RESMAN.EXE from locking up?

I have a Win2000 PC, PCI-MXI-2 to VXI test system that resman.exe will lockup every time its run. It always stops at "Configuring Extender 0". The resman.exe process cpu time is 99% and cannot be killed. I have tried running resman.exe directly from MAX and got the same result. The test system has been setup and worked for almost a year and no hardware changes have been made. However, this started after checking the "Enable Legacy Plug and Play" option for the LPT1 port settings in the device manager. The option was unchecked, but resman.exe continued to lockup. How can I get resman.exe to work again?
0 Kudos
Message 1 of 4
(6,256 Views)
The lock ups were caused by the MXI-2 cable that was partially connected to the PCI-MXI-2 card. I have reproduced this error on an identical system as well as several other lock ups and errors.
0 Kudos
Message 2 of 4
(6,256 Views)
I have seen ResMan lock up at this point before. A few things to check are whether disconnecting the MXI-2 cable when the software is locked up will actually end the lock-up. If this ends the lock, I would recommend trying another cable or ensuring that your cable is connected in the correct direction. Antoher thing to check is that the Logical Address of the MXI-2 in the VXI chassis is equal to a power of 2. (i.e. - 1,2,4,8,16,32,64,128), this could also cause ResMan to behave incorrectly.

Anthony Bacak
National Instruments
Applications Engineering
Message 3 of 4
(6,256 Views)
Thanks for the response. You were dead on. The cable was partially disconnected.
0 Kudos
Message 4 of 4
(6,256 Views)