Showing results for 
Search instead for 
Did you mean: 

Bus error when accessing a VME device in A24 space through the PCI-MXI-2 and VME-MXI-2 boards with VXI-VISA

I'm trying to access an Agilent metrology board (10895A) in a VMEcrate from a PC (pentium 3) running Labview 7.1, with Windows XP.
I'm using the PCI-MXI-2 and VME-MXI-2 boards with VXI-VISA to make this connection.

I tried to configure these devices through MAX. It seems that the two MXI board are configured correctly(at least for the novice I am), since I can easily open Visa sessions in A24 and A16 adresses spaces to access (read) their registers.
However, the Agilent board generates systematically a bus error when I attemp to access its registers.

The Agilent's board base adress(A24 space) is configured to be 0x1000000 to 0x10001FF (Memory space needed 512 bytes) and no other board is refering to these adresses.
Does anyone has a glue on what is going wrong and how I should set the Interrupt level, Handler level and Shared Memory parameters?

In fact, a configuration has been working for a while with success on the system, but as I had to reboot the PC and the rack, the system is now not responding anymore.
I saved the configuration files of these board when it was working and loaded it again into the system; but I still get this bus error and cannot access the Agilent VME board anymore.

Any help would be great.
0 Kudos
Message 1 of 1