SystemLink Forum

cancel
Showing results for 
Search instead for 
Did you mean: 

PXI showing partially connected to systemlink server

Solved!
Go to solution

Hi I am trying to connect a PXI 8880 to but it is showing partially connected as the connection Status. It was connecting to the server successfully, but now it is not. I have checked the systemlink server configuration it is all default.I am using selfsigned certificates as the HTTPS: settings. I refered to this article(https://forums.ni.com/t5/SystemLink/Systemlink-problem-with-quot-Partially-connected-quot/td-p/41801...) for help but was unsucessful in resloving the issue. I have also tried to connect a cRio but i am having the same problem. 

zombae_0-1676606786887.png

zombae_1-1676606801225.png

 

0 Kudos
Message 1 of 3
(1,566 Views)
Solution
Accepted by topic author zombae

Make sure your self-signed certification isn't expired and that the hostname/IP address on the certificate matches what is listed as the "Preferred host name" in the web server as well as matches how the targets are trying to connect. In general, also verify that your clients can ping your "Preferred host name". 

0 Kudos
Message 2 of 3
(1,538 Views)

Thanks for the help it worked. My systemlink server kept defaulting to us a older expired certificate. When creating a new certificate i also deleted the ::1 setting from the certificate. 

0 Kudos
Message 3 of 3
(1,463 Views)