SystemLink Forum

cancel
Showing results for 
Search instead for 
Did you mean: 

How to run Temp Monitoring Example on local SystemLink Server

Hello Community,

 

At these days I'm starting with WebVIs and SystemLink. I found the "Temperature Monitoring Web App Example" and a tutorial from Jim Parrot, where he explained how to deploy the WebVI in SystemLink Cloud and send data from my local VI. This worked well and gave me instant success.

Now I would like to host the WebVI on my local SystemLink Server instance (which I successfully already did) and access it from my LabVIEW2019- "Temperature Monitoring with Tags and Messages.vi". With the installation of SystemLink Server I gave the user "admin" a password, and this is the only user the server instance knows.

So I try to open the HTTP- Connection with the following credentials and URL:

 

SystemLink Credentials.PNG

 

This passes "Open Configuration HTTP.vi" well, but it gives me an error from "Open Tag HTTP.vi", trying to open "Test1.Status". The error message is:

 

Error -251043 occurred at NI Skyline Utilities.lvlib:Parse HTTP Error.vi:5080001

Possible reason(s):

A supported version of the '#' web service is not installed on the configured web server.


Complete call chain:
NI Skyline Utilities.lvlib:Parse HTTP Error.vi:5080001
NI Skyline Utilities.lvlib:Execute HTTP Verb.vi:7500001
NI Skyline Tag HTTP Library.lvlib:Open Existing Tag.vi:1500001
NI Skyline Tag HTTP Library.lvlib:Open Tag.vi:1540001
NI Skyline Tag HTTP.lvclass:Open Tag HTTP.vi:3570001
Temperature Monitoring with Tags and Messages.vi

 

I copied the URL of the WebVI from the SystemLink Server GUI, which includes the '#' part mentioned in the error message.

 

On the WebVI part I left the "Open Configuration API Key" with no server url and api key, as in the SystemLink Cloud example:

 

WebVI Start.PNG

 

If this is causing the problem, what URL and API Key do I have to input here?

 

Greets, Dave
0 Kudos
Message 1 of 3
(1,188 Views)

To explain more: This is my idea to start using WebVIs, hosted on a local server and send tag data to it. If this is not the right approach, where and how should I start?

Greets, Dave
0 Kudos
Message 2 of 3
(1,166 Views)

Hi daveTW,

 

The How to Build a Web UI for Your LabVIEW-Based Test System presentation goes through more detail on setting up WebVIs with a LabVIEW application.

 

I'd recommend going through the full presentation to get an understanding of the features and architectures for web-enabling an app. The first demo in the presentation is a walkthrough of setting up with SystemLink Cloud and the second demo shows the changes required to use a local NI Web Server.

 


Milan
0 Kudos
Message 3 of 3
(1,037 Views)