Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

cRIO 9045. Unable to deploy labview project or enable embedded UI.


LabVIEW 2019 SP1

LabVIEW real time module 19.0.0

NI CompactRIO drivers and MAX 2022 Q3

The host machine that I am running MAX on and trying to deploy LabVIEW code from is a company computer running Windows 10.





This problem started as not being able to deploy a LabVIEW project to a cRIO 9045. I had the issue described in this article where the cRIO is identified correctly under the remote devices section of MAX, but LabVIEW gives a failed connection error when trying to deploy a project.


I went through all the troubleshooting steps in the above article, and none of the steps listed solved the problem. I then proceeded to the last step in that article of formatting the cRIO and restoring it to factory default settings.


After formatting, I install software on the cRIO through MAX, and select NI CompactRIO 19.5 - September 2019. MAX shows that all software was installed correctly.


After these steps, the cRIO is stuck in the following state.


•LabVIEW still fails with the same error when trying to deploy a project.

•A monitor connected to the cRIO displays the NI Linux Real-Time terminal with the message “To start the embedded UI, enable it in NI MAX and restart the target”

•When the cRIO is selected in MAX, there is no option to enable the embedded UI. The only options under the system settings tab are “force safe mode” and “enable console out”, but both of these options are grayed out.

•The log in button is grayed out, the set permissions button can be clicked, but does nothing.

•Remotely restarting the cRIO, or changing its network and time/date settings through MAX works correctly.

0 Kudos
Message 1 of 3

Hi alex


If you successfully installed softwares to CRIO by MAX, you would add and get online on labviee that target too. If this could not happen, maybe firewall or antivirus interfere to connection between labview and target. You should check that.


Also as i know, for embedded ui enabling, you should install a package on CRIO to display that checkbox on MAX. Check vision or panel named packages.


0 Kudos
Message 2 of 3

I've somewhat solved the problem.


The issues I was having were happening on a company computer. I'd already had IT give me rights to change my network adapter settings, as well as allowing traffic through all the ports listed on this article.

What Ports Do I Need to Open on My Firewall for Communicating with CompactRIO? - NI


However, I was still having the issues described in my first original post. I eventually brought my own personal laptop into work, installed the LabVIEW trial on it, and was able to connect and deploy software to the cRIO following the exact same steps I was trying on the company computer. I'll have to work with my IT department to understand where the problem is.

0 Kudos
Message 3 of 3