Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

Does LabVIEW 2014 support CDAQ 9136

Solved!
Go to solution

I am using LV 2014 SP1, I wanted to buy CDAQ 9136 Windows controller for one of my project. I want to understand if I can use the LV 2014 SP1 with DAQmx15.1 to program for this controller?. CDAQ 9136 user manual doesn't say anything about LV support, just says DAQmx 15.1 is supported. 

 

When I tried to add a CDAQ target in LV2014 SP1 with DAQmx15.1, it does not show CDAQ 9136. I am not going to use the realtime version of CDAQ 9136, but still I am confused. Any help would be greatly appreciated.

 

LV 2014 Select a target

Nanda
0 Kudos
Message 1 of 3
(3,325 Views)

Hi Nanda,

 

In a way, the Windows version of the cDAQ-9136 can be viewed as just another desktop PC. You would connect a mouse, keyboard and monitor to it and program it directly without needing a host PC.

 

Say you have a 9401 DIO module in the chassis, it would show up in MAX like the screencap below. From the Windows OS on the cDAQ, you can launch LabVIEW and use it like you would with any other common DAQmx devices, for example, a USB-6501.

WincDAQ.PNG

 

To answer your question, DAQmx 15.1 is compactible with LabVIEW 2014 SP1. You will be able to use it.

 

I think it is a good idea for you to call 1 (800) 531-5066. You will be able to speak to an engineer in detail on why you want to buy it and how to use it.

Ren H.
Applications Engineering
National Instruments
0 Kudos
Message 2 of 3
(3,302 Views)
Solution
Accepted by topic author Nanda1985

Nanda,

 

I'd like to clarify compatibility for the NI-9136. It is compatible with DAQmx, starting with DAQmx 15.1. This means it can be used as a normal cDAQ chassis in any version of LabVIEW with DAQmx 15.1 or later installed (within reason.) However, real-time compatibility with the cDAQ-9136 was not introduced until LabVIEW Real-Time module 2015, which is only compatible with LabVIEW 2015. Thus, in order to use the cDAQ-9136 as a real-time controller, you'll need to have LabVIEW 2015 and LabVIEW real-time module 2015 or later. This note can be found in DAQmx 15.1 notes for supported devices.

Austin
Staff Software Engineer
NI
Message 3 of 3
(3,244 Views)