PXI

cancel
Showing results for 
Search instead for 
Did you mean: 

Why PXI hangs if no application is running in it?


Hi all
    There i come up with very interesting problem that never occured before well i'm using PXI-8186 RT controller with PXI-1031chassis & two PXI-6508 digital I/O cards & PXI- 8420 16-channel serial interface. My host PC is using Windows Xp
now previously I was using my application & after 20-30 days the system hangs & nothing appears on monitor connected to my PXI controller
& after that the problem keeps on increasing gradually & then after every 10-15 min it starts hanging then i have to format my system to make it work poroperly  and same story happens even after & i always thought that there is some soft corner left in my application which leads to the hanging of the PXI.
But this time when the PXI hangs & like always i fromated it . It didn't work properly i.e. the PXI keeps on hanging after i formated & that again within 20 min or so. Only Labview RT & other drivers are installed not my application.
this problem is bothering me & stoping my system to work on the production line.
If anybody know the cause of the problem & the way to rectify it
Please send it to me
Regards
Love Diwan
There is always a better way to do things.................. "Just Find It"
0 Kudos
Message 1 of 4
(2,493 Views)
Hi Love,

Sorry to hear you're having problems with the system.  It sounds like you're having overheating issues with the controller, and it's shutting itself down to save itself from physical damage.

Here's a few ideas:

1.  Boot into the BIOS and let it sit there for the 15-20 minutes.  To do this, turn on the system, and press the DEL key when prompted.  If things shut down here as well as in Windows, then it's safe to say that it's NOT a software problem.
2.  Clean out the fan, and make sure that the fan is spinning well when you power it on.  Now try running again.
3.  Set the fan speed switch to HIGH.
4.  Check out this KB and monitor the system temperature with a 3rd party application:  http://digital.ni.com/public.nsf/websearch/11E7232579F5995486256AA800431998?OpenDocument
5.  If necessary for more testing, remove the system from the manufacturing floor and bring it into an air-conditioned room and see if it still happens there.

I'd like to know what temperatures are in there.  As an FYI, the PXI-1031 is rated from 0 to 50 degrees C.  See the user manual at http://www.ni.com/pdf/manuals/323681a.pdf for more information.

Thanks, let me know how all of this goes,
mike
Message 2 of 4
(2,483 Views)
Oh, and I forgot to mention -- I'm not 100% sure that it's temperature, but that's what it seems to be for now.  If the above solutions don't work at all, then we can try another avenue.

mike
Message 3 of 4
(2,482 Views)
Hi Berto
      Thanks for the reply .
Yaa i found that the problem is due to temperature & the fan of my chassis is not working. but when i tried with the new controller which is windows based controller then system didnot hangs.
Suggest if  it is some sign of problem with my application
Regards
Love Diwan
There is always a better way to do things.................. "Just Find It"
0 Kudos
Message 4 of 4
(2,462 Views)