Showing results for 
Search instead for 
Did you mean: 

Devices in PXI-1033 appear in MAX, chassis does not

I have a PXI-1033 with two PXI-2529s installed in it. Both PXI-2529 devices appear in MAX and pass self test, but the PXI-1033 does not. The PXI-2529 devices show "N/A" for PXI Chassis and PXI Slot, and are listed along side the DAQ device that is in a PCIe slot in the PC. Both PXI-2529s pass self-test and display their serial numbers in MAX. I can operate the switches on them using the soft front panel.


The drivers are older, but a proven (and version locked) configuration that has been deployed 5-6 times prior. The PXI-1033 is always on before the computer is turned on. I have tried changing the slot of the PCIe MXI card and resetting the MAX configuration data, but the problem remains.


I'm at a loss for what else to try. I could uninstall/reinstall PXI Platform Services, but I'm not sure what else to do. Any ideas?

0 Kudos
Message 1 of 9


Which version of NI-DAQmx and NI-Switch do you have?

Which OS do you have and which PXI Platform Services are installed?

Which MXI card do you have?

If you go to Device manager can you see your MXI card?

Normally the MXI-Express have some LEDs that provide information, can you check the LED lights?

 Can you upload a screenshot of your NI-MAX?


0 Kudos
Message 2 of 9

Bear in mind, this system mirrors numerous others already deployed with a particular version of LV, TestStand and the related drivers. The setup is validated and the customer expects the same setup. So "update the drivers" is a bad answer. That said:


Windows 7 64 Pro

(All NI SW installed from NI Dev Suite 2012 DS2 discs)

LabVIEW & Teststand 2012

Switch Exec 3.6

NI-DAQmx 9.5.5

NI-Switch 4.5.5

PXI Platform Services 3.0.3


The MXI card appears as a bridge, I forget the exact name.

The link LED on the chassis is solid green, unless there is communication to a switch. Then it toggles between green and red.


I decided to wipe the computer and try installing everything again, so I don't have a MAX screenshot at the moment. I'm hoping that something just didn't install correctly. I should know more soon.

0 Kudos
Message 3 of 9

MAX screenshot attached, showing missing chassis. Re-installing did not correct the issue, unfortunately.



0 Kudos
Message 4 of 9

I removed the PCIe DAQ card from the system as a precaution. The PCIe 8361 was tried in every PCIe slot (2 x1, 1 x16). System does not boot with it in the x16, both x1 slots have the same behavior. I tried the MXI compatibility software, but my 8361 does not have DIP switches. I saw no change in behavior. Windows event log shows an error for MXI compatibility in this case (basically that it is not active because no mode 1 device is present). It also shows an error for ACPI device #5 which I suspect is the MXI card.

I updated the PCs BIOS to the latest version. It is a Dell Inspiron 3650.

0 Kudos
Message 5 of 9

Hi Can we try this

1. Reset the MAX database (http://digital.ni.com/public.nsf/allkb/2C7480E856987FFF862573AE005AB0D9) 
2. Test the devices on a different computer model that has Windows 7 
3. Disable the PCIe native mode (on the original problem computer) in the command prompt window. Here are the steps: 
a. Open the start menu and type "cmd" in the search box; right-click on "cmd.exe" and run as administrator. 
b. In the command window, type "bcdedit /set pciexpress forcedisable".   
c. Reboot. 
If that doesn't work then please go back to set it back to default by using the command prompt window and enter the command, "bcdedit /set pciexpress default" 
0 Kudos
Message 6 of 9

Good ideas, thank you. Unfortunately, the situation remains the same. I did the MAX data reset (I had actually done it during earlier troubleshooting as well, but I did it again in case). We don't currently have another Win7 machine in the office, it is unique to this customer's app. I could try it on a different PC in the office with Win10 if that helps. Did the PCIe native mode disable, same results in MAX after rebooting. Since it didn't fix the issue, I did the additional steps to re-enable PCIe native mode.


The most puzzling part is that it appears I can talk to the switches fine in the PXI chassis. The self-test passes for them, and I can toggle switches using the soft front panel and hear them click on and off. It's just the chassis itself that doesn't want to detect. Unfortunately, I think that will prevent me from applying the SwitchExec configuration to the system.


Does that narrow down the potential cause at all?

0 Kudos
Message 7 of 9

Hi ! 

Thanks for all the information.


Did you tried on a different PC?

Also, I want to share with you this Troubleshooting guide

Also here is the: NI MXI-Express BIOS Compatibility Software

It would work for the 8361

0 Kudos
Message 8 of 9

It sounds like there's a problem with your chassis (verses a software problem).  Do you have a 2nd chassis you can try to verify?


Have you tried unplugging the chassis for 30 seconds?  Some of the circuits involved in chassis ID operate from always-on power and don't get cleared by a normal power cycle.  If that doesn't fix it then I think you're looking at a broken chassis.


Side note: the PXIe-8361 that ships with the PXI-1033 doesn't have the switch for the BIOS compatibility software (as you've noticed).  There's another version of the card with the same model number that supports it, but this isn't the kind of problem that would be fixed by that.


- Robert

0 Kudos
Message 9 of 9