NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

"Disable tracing" as part of custom step type behavior

Solved!
Go to solution

Hi !

 

Currently writing custom step types based on sequences (my step type's default adapter is a sequence), I would like to set the "disable tracing" right in my step type definition.

The problem is that this option isn't visible in the 'Default Run Options" tab... The only way I found to do this is using Pre and Post Expression to set 'ThisContext.Tracing = True /False'.

But I don't like the fact to use Pre/Post Expressions in my step type (I would prefer to let it blank for end users).

 

Is there any way to achieve this without using Expressions ?

CLA, CTA

View Cyril Gambini's profile on LinkedIn
0 Kudos
Message 1 of 7
(2,370 Views)
Solution
Accepted by topic author CyGa

Hi zyl7,

 

In your custom step type, set the property TS.SData.Trace to "Off" (without the quotes).

 

Hope this helps.

 

-Jack

Message 2 of 7
(2,364 Views)

Hi Capt Jack !

 

I'd love to, but how do I do this from the step type defintion ?

CLA, CTA

View Cyril Gambini's profile on LinkedIn
0 Kudos
Message 3 of 7
(2,362 Views)

In the Types definition for your custom step type, just click the '+' to open up the subproperties of that custom step type definition. You should then see the Root TS container, just follow the subproperty path to the Trace subproperty.

0 Kudos
Message 4 of 7
(2,360 Views)

Here a printscreen on the properties available for my custom step... No TS container...

Am I missing something ?

CLA, CTA

View Cyril Gambini's profile on LinkedIn
0 Kudos
Message 5 of 7
(2,358 Views)

Kinda; Open the Station Options, select the Preferences tab, and enable the 'Show Hidden Properties' option. The TS container will then magically appear!

 

-Jack

0 Kudos
Message 6 of 7
(2,354 Views)

Works fine !

 

Thank you very much !

CLA, CTA

View Cyril Gambini's profile on LinkedIn
0 Kudos
Message 7 of 7
(2,337 Views)