NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

NI TestStand Python Adpater Support for 3.10

Solved!
Go to solution

I'm trying to select Python 3.10 as with TestStand (2021).

Unfortunatly I cannot select 3.10 as Python version in the adapter settings.

I double checked my environment settings and the equality of TestStand and Python bitness (both 32-bit), but the selection for 3.10 doesn't appear.

I also installed Python 3.9 to check if there are some issues with my system, but this version immediatley appears in the Python version selections.

 

Any suggestions how to get Python 3.10 selectable?

0 Kudos
Message 1 of 3
(124 Views)
Solution
Accepted by topic author cjanz

TestStand 2021 does not officially support Python 3.10. Hence, it does not show in the Python adapter settings dialog.

 

Even though version 3.10 is not officially supported, you can still use it. In the Python adapter settings dialog, the drop down control is editable. So click on it and explicitly type 3.10. This should enable TestStand to use 3.10 version.

 

I believe everything in 3.10 version should work correctly in TestStand 2021. However, since it is not officially supported, you might not get full support from NI if you hit any issues.

 

-Shashidhar

0 Kudos
Message 2 of 3
(94 Views)

Thank you, saved me a lot of time!!!

0 Kudos
Message 3 of 3
(88 Views)