NI TestStand

cancel
Showing results for 
Search instead for 
Did you mean: 

Is there a permrefs.llb for labview 6.0i?

I just upgraded from 5.1.1 to 6.0.2 and now I'm getting errors with the permanent references library I use in my teststand sequences.
0 Kudos
Message 1 of 2
(1,955 Views)
Update:
I found the offending vi, and it is fixed. Within the permrefs.llb is a vi called "Permanent Reference Daemon.vi". It had broken wires after my upgrade to 6.0. The broken wires were in the "destroy" and "create" cases of the above mentioned vi. The fix was to add the "type cast" tool in between the cluster and the UDP connection reference for both "create" and "destroy" cases. Apparently 5.1 did some automatic data type conversion where 6.0 does not. I will attach the vi to this message, then you can either overwrite the vi in your permrefs.llb or use is seperately. I could not find any official updated version of permrefs.llb for 6.0.
0 Kudos
Message 2 of 2
(1,955 Views)