Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

dll failed to initialize error when opening NI-DAQ or NI-DAQmx VIs

I have installed LabVIEW 7.1 on a laptop (Toshiba Satellite S5100-503) using Windows XP Pro. When I try to pick a NI-DAQ or NI-DAQmx .vi I get an error message stating that lvdaq.dll or nilvaiu.dll have failed to initialize. I have tried unistalling and installing the whole package and the palBase-trick mentioned as a solutions to some problems with NI-PAL drivers. I have also tried to update the hardware drivers from Toshiba's website.

I have traced the problem to NIPALK service not being able to start by looking at the error events with Window XP's Event Viewer. Could anybody tell what might cause this and what could be the solution?

I do not have any measurement hardware for the laptop because I am using it as a host for a real-time target.


0 Kudos
Message 1 of 4

What version of Traditional NI-DAQ, NI-DAQmx have you installed, have you tried to repair these installations also? I assume you are logged in as an administrator!


0 Kudos
Message 2 of 4
I tried versions 7.3, 7.4, and 7.5. The result was same with every version.

I don't know what had went wrong with the installation. However, after I manually deleted and then re-created the nipalk service from the command line everything magically started working. I don't know whether creating the service using option "error= ignore" was the cure but I didn't try the default option because ignoring seemed to work.

    Kari Roth

P.S. The commands I used were:

sc delete nipalk

sc create nipalk binPath= System32/drivers/nipalk.sys start= boot error= ignore group= Base DisplayName= NIPALK

0 Kudos
Message 3 of 4


If you are still having problems, see

It fixed my lvdaq.dll problem

0 Kudos
Message 4 of 4