Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

When I send data out of DAQ pci 6120 get error -10010. I have even number buffer size

I am using PCI 6120 for sending and receiving back MLS sequence .But I am getting error -10100 when I send data out . Sometimes it sends first instant of data then shows error -10010. I am using even number buffer size . The exact wording of error is "Error -10010 occurred at AI Control
Could you pleas help me on this issue.
0 Kudos
Message 1 of 4
Hello DSPGUY1,

I'm not sure what else can be causing the error besides trying to write out an odd number of points. Could you please post your code so we can take a look at it?

DE For Life!
0 Kudos
Message 2 of 4


I got a problem when I run my labview code. I got the following two errors.

In labview code I get this error immediately when I run it.

“Error –2147220727 occurred at DAQmx Create channel (Ao.voltage-Basic). Vi.

The error code is undefined. No one has provided a description for this code, or you might have wired a number that is not an error code to the error code output.”

Now when I tried to open MAX to see the device/interface I got the following error.

“nimax.exe—The instruction at “0x1cd6e15d” referenced memory at “0X0000002c”. The memory could not be “read”.

I have been using this labview code for last wix months. Never had any problem. However some viruses infected my computer recently and after cleaning it I try to run my labview code and got the above-mentioned problems.

I’ll really appreciate your help in this regard.




0 Kudos
Message 3 of 4


It sounds like after the virus either your MAX installation or DAQmx installation may be corrupt. So I would recommend uninstalling DAQmx, and then reinstalling it. Here is a link to the current drivers.

Hope that helps.



0 Kudos
Message 4 of 4