Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Simulated 9213 giving wrong thermocouple readings (on order of -1E30)



I'm trying to set up a simulated 9213 plugged into a simulated cDAQ 9174 and am having issues.


I created a task to read from 16 K-type thermocouples, and when I run it in "1 Sample (On Demand)" mode it works fine, but when I run it in any other mode the last two values (ai14 and ai15) are usually incredibly wrong.


I've tried different sampling rates and that doesn't seem to help. Occasionally ai15 will read a normal value, but ai14 is always an extremely large negative number.


Does anyone know why this is hapenning? I tried searching and couldn't find anything similar..


I expored my DAQmx task and devices to an ini file and attached it.





0 Kudos
Message 1 of 3

Hi NickG88,


Oops, please disregard the post above!  I completely missed that you mentioned it's a simulated DAQ device.  We've actually been able to recreate the issue you're seeing and we're looking into it.  For now, however, I don't have a solution to offer.  Sorry about the confusion!

Julian R.
Applications Engineer
National Instruments
0 Kudos
Message 2 of 3

Okay. Good to know it's reproduceable and not just on my end.

0 Kudos
Message 3 of 3