Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Problem two analog output generation NIDAQ mx

Hello everybody,


This is my first post so please forgive me if I make any mistake explaining myself. I am working in a MAC environment with LabView 2012 and with  a DAQ NI USB-6218. I am trying to generate two analog signals at the same time. A first square signal and a second constant amplitude signal.


I made a code that worked as expected before but I don't know why it doesn't work anymore. I am very confused with its behavior and where is the problem. In summary, when I start the code, I have my square signal but my constant voltage signal is always placed on zero volts no matter what I do (measurements and outputs viewed by oscilloscope). Can you please give me a hand to solve this problem?.


As I said, it worked before and I didn't touch the code since then. I cannot understand what is happening.


Thank you in advance


Download All
0 Kudos
Message 1 of 2

Hello DrDi,


I looked over your VI, and it should work as you said, even more if you have changed nothing and it stopped to work suddenly.

- First, you should look at your outputs separately : Do they work with NI MAX when you generate a constant signal, or a sinus ? (ao0 and ao1)

- Try the same on LabVIEW, with 2 different tasks in parallel, configured with N samples 1 Channel

- Try each task separately on LabVIEW thanks to the example in the Example Finder


These first steps will inform us about is your module working or not.







0 Kudos
Message 2 of 2