Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Nipalk.sys apparently causing Blue screen

Afternoon,

Please excuse the vagueness of some of this, but I'm not the person that actually uses the machine this is about. I work in the IT department and the person that used to look after all this is no longer here. So they have come to me.

I have a Windows XP laptop that is connected to an LGCM 014-LG-TE-2000 calibration machine, there is a program that was created in LabView 7.1, that is used for testing and calibrating pieces. The program has three voltage settings, 5V, 9V and 28V. The 5 and 9 volt buttons work fine and when pressed turn on the light on the calibration machine, but when the 28V button is pressed we get a BSOD, attached picture 1.

Everything I've read indicates a driver issue, so I have downloaded NIDAQ 7.4 and NIDAQ 8.3 and ran repairs on all the installed parts that I can.

I have also included a kernel memory dump. if anyone can advise on what can be done then I would greatly appreciate it.

 

Thanks

David Kernaghan

Download All
0 Kudos
Message 1 of 3
(1,257 Views)

Hi David,

 

Thanks for your post.

 

I'd like to ask you to try a few steps:

 

  1. Do you have another machine available to you, from which you can try the code?
  2. Are you still using the LabVIEW 7.1 version?
  3. Please post your max report, to give us an idea of your hardware and software compatibility.

 

Creating a MAX Technical Report to Document Configuration Information

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P9mPSAS&l=en-GB#

 

Thanks,

 

Kind regards

YD

0 Kudos
Message 2 of 3
(1,227 Views)

Morning,

Thank you for the respsonse.

We do have another machine that we tested the program on, we plugged in the device and restarted and it seemed ok, until we hit the 28V switch and it blue screened, same as the other laptop, which I suppose it more indicative of a hardware fault.

We are still using LabVIEW 7.1 on Windows XP. I upgraded the NIDAQmx drivers from 8.3 to 8.7.1 with the same result.

I've attached the MAX report as requested.

0 Kudos
Message 3 of 3
(1,225 Views)