Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

NI-DAQ + NI USB-4431: Error 233054

Solved!
Go to solution

Hello everybody,

 

First of all, here is my config:

- Dev PC: Win 7 - 32 bits

- LabView 2009 - 32 bits

- NI DAQ 9.7.5

- Acquisition card: NI USB-4431

 

The problem: 

When I start my application right after having plug my acquisition card to my PC (or after boot), the DAQ Assistant give me the error 233054:

Capture.PNG

I did not found any explaination on this amazing tool which is internet, so  I come here! 😉

The only way I fount to go forward, is opening NI-MAX, ask to do an acquisition, ask to do a generation (which one works) and then, I can go back in LabView and launch my program!

The problem seems coming from initialization. But I don't see what I have to do to have it working every time! Any idea?

 

Best regards,

 

Harold

0 Kudos
Message 1 of 6
(4,236 Views)

Hello,

 

I found a corrective action request which documents this behavior as a bug in the driver setting an incorrect DDS clock rate. Try upgrading to the newest version of DAQmx and try again.

 

Best regards

0 Kudos
Message 2 of 6
(4,205 Views)

eloidi.k,

 

Will the newest DAQmx support LabVIEW 2009?  If not, can you check for a version that both corrects the CAR *and* still supports 2009 for sure?

 

-Kevin P

 

CAUTION! New LabVIEW adopters -- it's too late for me, but you *can* save yourself. The new subscription policy for LabVIEW puts NI's hand in your wallet for the rest of your working life. Are you sure you're *that* dedicated to LabVIEW? (Summary of my reasons in this post, part of a voluminous thread of mostly complaints starting here).
0 Kudos
Message 3 of 6
(4,184 Views)
Solution
Accepted by topic author haroldducept

Hello,

 

I just check the compatibility between daqmx driver and labview. I notice your daqmx driver version 9.7.5 is not compatible with labview 2009, that why, you have this deal.

The latest version of daqmx with labview 2009 is 9.7 see below

 

 

DAQmx and LabVIEW Version Compatibility:

http://digital.ni.com/public.nsf/allkb/B0D5630C0A50D5C6862578E800459248

 

So may you uninstall 9.7.5 and reinstall daqmx 9.7 see this link

Uninstall Software

http://digital.ni.com/public.nsf/allkb/AC6ED75D3D93375686256E8E00245F0D

 

Best regards.

0 Kudos
Message 4 of 6
(4,177 Views)

Hello everybody!

 

Thanks for your replies!

Unfortunately, I have to work on something else for the moment. So I will come back on this subject in a few days.

 

So, following your advices, I will uninstall my NI-DAQ version to install the 9.7 and come back here to tell you if it works!

 

Thanks

 

Harold.

0 Kudos
Message 5 of 6
(4,161 Views)

Hello all,

 

As promised, I've followed your instructions and it seems it works!

 

Thanks a lot for your help! I would'nt have find it alone!

 

Regards,

 

Harold.

0 Kudos
Message 6 of 6
(3,998 Views)