Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

How to connect two boards using RTSI?

Hi,
 
I installed two NI 6034E boards and then connect them using RTSI cable.  To configure the devices, I clicked Measurement & Automation=>Devices ans Interfaces and right-click the device under NI-DAQmx folder. Selecting properties, RTSI Configuration tab showed RTSI Cable "None".
I am not sure whether or not connection using RTSI cable is ok?
 
Thanks in advance.
 
Juntack Lim
0 Kudos
Message 1 of 5
(4,370 Views)
Juntack,
 
Right click on the DAQmx Devices tab and select Create New DAQmx Device->RTSI Cable.  This cable will now show up as a DAQmx device.  You can then right click on it and add devices to it.  At this point DAQmx will be aware of the fact that your devices are connected by the RTSI cable, and can take advantage of it to route signals between you devices, as well as protect against double-driving RTSI lines.
 
Hope this helps,
Dan
0 Kudos
Message 2 of 5
(4,367 Views)

Hi Dan,

Thanks for your advice.  I followed up and It worked.  When I click on  RTSI cable under "NI-DAQmx Devices" folder,  two NI-6034E boards successfully showed up in "Connected Devices" tab. 

After right click on RTSI cable, I don't know the RTSI lines(0,1,2,3,4,5,6,7) to be checked in "RTSI Cable Reservation" tab.

Thanks,
Juntack lim
0 Kudos
Message 3 of 5
(4,359 Views)
Juntack,
 
Let me give you a little background on why that tab exists.  Prior to DAQmx, most signal routing had to be managed by the user.  By this I mean if you wanted to share a signal between 2 devices, you would have to explicitly pick a RTSI line, export a signal on it from one device, then use that line as a clock or trigger source on another.  It was up to the user to ensure that no 2 devices would drive the same line.  One of the features of DAQmx, is that this new drive can automatically figure out this routing for you, and ensure that no 2 tasks using DAQmx will double-drive a RTSI line (as long as the RTSI cable has been added in MAX, and the appropriate devices attached).  However, since some users us a combination of DAQmx and traditional DAQ, it is possible that they have old applications which use some RTSI lines.  Because traditional DAQ does not have the resource management like DAQmx, this tab allows the user to let DAQmx know which lines may be used by other applications.  If DAQmx needs to drive a RTSI line, it will not be allowed to drive any of the lines checked in this tab.  If the only devices on the RTSI cable are your 6034's, and you are using DAQmx only, then you should not have to worry about this at all.
 
Hope that makes sense.  Let me know if you have additional questions.
Dan
Message 4 of 5
(4,342 Views)

Hello,

 

I was able to add RTSI cable under the Devices tab by doing right click on devices and interfaces>>create new>> add RTSI. But When right click on new RTSI added it doesn't give me any option of adding the two boards I have i.e PCI 7833R and PCI 1422. 

Although these two boards are well connected infividually and shown in DAQ but I can not add them through RTSI.

 

Any help?

 

Thanks.

0 Kudos
Message 5 of 5
(2,428 Views)