Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

Gentoo installation: installUtility.sh and init_mm

Hello to the developers of NI-KAL!

 

I am running a gentoo installation and am now trying to install NI-KAL-1.10. (gcc version 4.3.4, kernel 2.6.31 without PAE)

 

I did the following:

 

1. mount -o loop NIKAL110.iso ni-kal

2. I copied the contents to another folder, where I could write to

3. I extracted the contents of nikal-1.10.0f0.tar.gz and edited bin/installerUtility.sh:340: I changed

 

currentGCCVersion=`$CC -v 2>&1 | tail -n 1 | $SED 's/.*gcc[a-zA-Z (]\+\([0-9][^ )]\+\).*/\1/'`

 

into

 

currentGCCVersion=`$CC -v 2>&1 | tail -n 1 | $AWK '{ x=1; while (x <= NF && $x !~ /^[0-9]\.[0-9]\.[0-9]*$/) x++; print $x }'`

 

which was already suggested in this thread because the script aborted due to "version mismatch". Installing then with "--nodeps" worked finally... almost 🙂 This is the first thing I wanted to tell you, because I think, the awk-style GCCVersion is better than the sed-styl one.

 

The second thing is actually the question. The point where I failed finally is the init_mm problem. I installed kernel 2.6.27 and will downgrade the older kernel within the next few days. But: are you going to release a version of NI-KAL which doesn't need the init_mm anymore? This would be awesome!

 

Thanks and best regards,

 

Alex vZ

0 Kudos
Message 1 of 2
(3,022 Views)

I now downgraded to kernel 2.6.27. With substituting the lines in the installerUtility.sh files (in the tar.gz from the iso's as well as in /usr/local/natinst/nikal/bin/) the installation seemed to work without errors. I first installed NI-KAL 1.10 and then installed NI-VISA 4.5.0.

 

Ich now have the following problem:

 

 $ visaconf
libnipalu.so failed to initialize
Perhaps you need to run updateNIDrivers

 

I indeed did an updateNIDrivers but nothing changed. The modules nikal and nipalk can be loaded without error (warning about the init_mm stuff). I attached the niSystemReport.

 

Does anybody know, what is wrong with the installation?

 

Thanks in advance,

 

Alex

0 Kudos
Message 2 of 2
(3,018 Views)