Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQmx update causing network DAQ problems

I have a set of cDAQ 9188s that are plugged into our network, with a computer to reserve a chassis and run an executable for our tests. The computers are running DAQmx 9.8, and I would like to update them to bring the drivers current. However, when I update DAQmx, I have a loss of communication to the cDAQs. If the chassis is already in MAX, I receive error -201250 when I try to reserve it or run a self test. If I try to add a chassis to MAX, I get error -201401, both related to the network properties of the device. By all indications, the chassis are fine, as they work with any system running 9.8, and one running 15.0.1. I have tried updating from 9.8, removing the old version DAQmx and installing the newest version, I have tried a force reinstall, all with the firewall disabled and without. I can see info about the chassis, Hostname, IP address, Status, etc, and I can ping the chassis with no problems.

 

One peculiarity of this problem, if I open the Network Settings Tab in MAX, it seems to load in the network properties, and then it seems like I can interface with the device with no issues, adding/reserving as expected. This behavior is specific to the session of MAX however, and it does not carry over if I close and reopen MAX or attempt to run a program on the chassis. 

 

I would appreciate any ideas on why I am having this problem and fixes for it. I am unsure of what difference there is between the computers that are not working with new drivers and the one or two that are. I have seen a few forum posts about people having similar errors, but none of the fixes people have found have seemed to work for me. 

 

Thanks for the help.

 

Luke

0 Kudos
Message 1 of 1
(2,863 Views)