Multifunction DAQ

cancel
Showing results for 
Search instead for 
Did you mean: 

DAQmx folder in \vi.lib\ missing

Solved!
Go to solution

I am trying to run DAQmx vis on a fresh installation of LV2014 SP1 (DAQmx Drivers 14.5.1) but the installation does not create the DAQmx folder in the vi.lib so my VIs (developed on a different machine) cannot find the required DAQmx VIs. I also have an installation of LV2015 on the same computer where the DAQmx drivers are installed and working (and the folder in the vi.lib also exists). Any suggestions on how to get the drivers working on my LV2014 installation?

0 Kudos
Message 1 of 6
(5,141 Views)
You need to install drivers after you install LabVIEW. Did you do that?
0 Kudos
Message 2 of 6
(5,138 Views)

Yes, I downloaded the drivers fresh from NI today, installed them, rebooted but I don't see the folder in the vi.lib. LV installation is about a week old.

0 Kudos
Message 3 of 6
(5,135 Views)

@fgeldmacher wrote:

Yes, I downloaded the drivers fresh from NI today, installed them, rebooted but I don't see the folder in the vi.lib. LV installation is about a week old.


Repair your installation of NI-DAQmx and make sure that support for LabVIEW 2014 is selected when it is being installed.

 

 

0 Kudos
Message 4 of 6
(5,127 Views)

Solution was to install the 2015 driver package again and rebooting. Thanks

0 Kudos
Message 5 of 6
(5,121 Views)
Solution
Accepted by topic author fgeldmacher

@fgeldmacher wrote:

Solution was to install the 2015 driver package again and rebooting. Thanks


The key is to remember is that NI drivers will detect what programs you have installed.

If you install a new version of LabVIEW after NI-DAQmx, you must repair the NI-DAQmx installation so that it can detect that you now have new version LabVIEW and therefore install the drivers it needs.

0 Kudos
Message 6 of 6
(5,119 Views)