Multifunction DAQ

Showing results for 
Search instead for 
Did you mean: 

Computer can't connect to mydaq



Last thursday i was able to work with my mydaq, but since this weekend i can't work with it anymore.

My computer does not seem to find my mydaq, it says that no device is connected.

Other computer are still able to find my mydaq, does anybody have any idea what changed since thursday that can have caused this change?



0 Kudos
Message 1 of 16

When I had that issue, I just had to change USB ports that I was using.  Not sure why that worked, but it did.


The other things to try are rebooting the computer and/or reinstall the DAQmx drivers.

There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 2 of 16

When you say your computer can't find it are you saying you can't see the device in MAX or you can't see the myDAQ in Windows Device Manager?

Aaron W.
National Instruments
0 Kudos
Message 3 of 16

They don't appear on both. And rebooting, installing software and changing USB port also did not work. 

0 Kudos
Message 4 of 16

You said you tried the myDAQ on another computer and it worked, correct? What about trying other USB devices on the computer that you are having problems with, have you tried that?

Aaron W.
National Instruments
0 Kudos
Message 5 of 16

Other USB device's work fine, it's probably something software related, but it used to work fine. 

0 Kudos
Message 6 of 16

You might try and reset your MAX Database, I'm not sure this is it, but it's easy enough to test out. This knowledgebase document describes the process. I'm assuming you have a newer version of MAX so the process should be just going to the Tools Menu and selecting Reset Configuration Data.

Aaron W.
National Instruments
0 Kudos
Message 7 of 16

This didn;t work either. 

0 Kudos
Message 8 of 16

Let's review:


- myDAQ use to work in this computer.

- myDAQ stopped working in this computer. (Anything happen to the computer from the time it was working to the time it stopped working? Virus? Blue Screen? Crash? Install software?)

- myDAQ still works in other computers

- you tried different USB ports on computer in question, still doesn't work.

- other USB devices work on the computer though.

- you reinstalled DAQmx, still doesn't work.

- Reset MAX Database configuration, still doesn't work.

- tried different USB ports, doesn't work.

- myDAQ doesn't show up in Device Manager


Let me know if any of the above are incorrect. I'm at a loss for what it could be.


The only other things I would try are:

- I assume you are a student, could you try to borrow another myDAQ and see if it works on your computer?

- I'm really at a loss to what other things to try. If another myDAQ doesn't work on the system then it might be a problem with the OS or something funny.



Aaron W.
National Instruments
0 Kudos
Message 9 of 16

Hello Wouter,


I just saw that you have also a parallel communication thread running through the mail support channels.
Would you like me to contact you via there or to continue via the forum?


All the suggestions that were made by Aaron W. seem to be logical.

Please let us know about the feedback you have concerning his last 2 questions and the question/confirmation about "what might have changed between thursday and the weekend".

Any small thing might help us along the way.



Kind Regards,
Thierry C - CLA, CTA - Senior R&D Engineer (Former Support Engineer) - National Instruments
If someone helped you, let them know. Mark as solved and/or give a kudo. 😉
0 Kudos
Message 10 of 16