Measurement Studio for .NET Languages

Showing results for 
Search instead for 
Did you mean: 

Problem with version of the NationalInstruments.Common library.

My problem looks like this:
I work on a NI USB 6008 I/O card. I installed everything necessary form the CD. Make a few programs and I started to write my own library.
When I want to try my library such a problem is appearing:

Could not load file or assembly 'NationalInstruments.Common, Version=, Culture=neutral, PublicKeyToken=4544464cdeaab541

It's weird owing to the fact that there where no NationalInstruments.Common, Version= on the  CD and why it want this library right now?

Sorry for my English
0 Kudos
Message 1 of 10
Can you try the following, I have a feeling your project may be trying to link to an old version of NationalInstruments.Common:

-open your project and then look at the solution explorer
- Expand the folder called References
- Delete NationalInstruments.Common if you have it
- right click on References and click Add Reference...
- on the .NET tab, select National Instruments Common and click OK

Now your program should be looking for the version of NationalInstruments.Common that is in your GAC.  Try to use your library now, and let me know if you are still having the same problem.
National Instruments
0 Kudos
Message 2 of 10
This help me. My project was using libraries from local copies of libraries for VS2003 and now everything is runnig smoothly.

0 Kudos
Message 3 of 10

I am having the same problem but been through my projects and can not see where it is referencing this version. What makes it even more annoying s that i have to applications calling the same code one application works and the other throws this exception on the common code. The applications are not referencing the NationalInstruments.Common library it is only the common code that does that


Does anyone have any ideas please?

0 Kudos
Message 4 of 10



Are both of Your applications calling the common code in the same way? Are they using exactly the same functions from the library? We can't help You without knowing the details of Your application. You should try to debug the code by Yourself. Find exactly the moment, when the error occurs, using conditional breakpoints or other debugging techiniques.

Best regards,
Maciej Antonik
National Instruments Poland
0 Kudos
Message 5 of 10



I am having the same problem actually.  I have installed (and removed and reinstalled) Measurement studio v 8.0.1 , and am receiving this error.  


Currently I'm trying to use the NI 488.2 libraries to communicate via  GPIB, but when attempting to run my program it gives the same exception that is listed in the first post. 


My highest version of nationalinstruments.common.dll is, and I don't have any versions on my computer at all.  I've checked the license file and done the suggestions in the Measurement Studio help files about refreshing license files, but this exception still persists.  This has me completely baffled and I would like to get some progress on this issue.  Is there any patch I can download to obtain ?



0 Kudos
Message 6 of 10



have you tried what Kristen suggested (second post)?.




0 Kudos
Message 7 of 10

For me it is the same problem, but I test the solution and it's doesn't change the problem.

I use Visual studio 2008 with mesurment studio 8.1.2.

Before I try apply  in visual studio 2003 and it's OK.




0 Kudos
Message 8 of 10



Please see this KB, it might be helpful:


If this doesn't help, search your PC for all instances of this library and check their versions. Also let us know the version your application requires (is it the same as in the first post?)

Best regards,
Maciej Antonik
National Instruments Poland
0 Kudos
Message 9 of 10

My probleme was solved by the intallation of measurment studio 8.6.1.


0 Kudos
Message 10 of 10