From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 

multi cameras detection problem

Hi,

 

I have 2 basler acA640 -100gm-mnt and Intel Pro1000 Dual Gig Interface card, PCIexpress 4x bus. I have installed NI IMAQdx. When I open NI Max the software is able to detect only one camera at time but not both cameras at the same time. Thus  I have under the tree of IMAQdx cam0 or cam1 but never cam0 and cam1 at the same time

 

Could someone help me please?

 

Alex

0 Kudos
Message 1 of 10
(3,566 Views)

What OS are you using? Is it Windows XP or earlier? On those OSes you need to bridge the two ports together to use them in link-local-addressing mode. On Windows Vista and later the OS properly handles this with no extra configuration.

 

If you are using XP, try following these two steps listed in the release notes:

 


  1. Installing the High Performance GigE Vision Driver

    If you have an Intel Pro/1000 Series gigabit Ethernet Network Interface Card (NIC), it is recommended that you install the High Performance GigE Vision Driver. This will ensure optimized performance and minimal configuration. To associate your hardware with the high performance driver, complete the following steps.

    1. Install your NIC.
      1. If Windows does not prompt you to choose a driver, proceed to step 2.
      2. If Windows prompts you to choose a driver, proceed to step 3.
    2. Right-click the NIC in the Device Manager, and select Update Driver.
    3. Choose not to connect to the Windows Update Web site, and click Next.
    4. Choose to Install from a list or a specific location, and click Next.
    5. Choose Don't Search. I will choose the driver to install.
    6. Click Next.
    7. Select National Instruments GigE Vision driver from the list, and click Next.
    8. Click Finish.

    Complete this for all listed network ports on your device

Configuring Multiple Ports

If you plan to use multiple ports with NI-IMAQdx, complete the following steps:

  1. Open the Network Connections window in Windows, and select all of the ports that cameras will be connected to by holding <Ctrl> while clicking each port.
  2. Right-click one of the selected ports, and choose Bridge Connections.

    Note: If you are not using the High Performance Driver, you will be unable to use jumbo frames on bridged devices.

0 Kudos
Message 2 of 10
(3,560 Views)

Thank you BlueCheese

 

It works

 

Alessandro 

0 Kudos
Message 3 of 10
(3,550 Views)

Hello, Blue Cheese

 

I am having a similar problem. I have two cameras, of the same make and model, connected to two PXIe-8234 GiGe interface cards. This was working just fine on a system I built in 2012, but the drive on that recently crashed and I'm trying to rebuild it. Unfortunately, now I can only see one of the cameras in MAX and I don't recall what I did before to make it work before.

 

I followed the suggestions shown in your response. The driver for both NICs is the NI GiGe driver, and, as I have an XP system, I have bridged the NICs per your suggestion. However, when I do that I no longer see either camera! (Before I bridged the ports I was able to see one of them.) I do not even have an IMAQdx entry in the devices list. When I remove the NICs from the bridge and delete the bridge port, I am able to get one of the cameras back, but I need them both.

 

Thanks in advance for any help you may be able to provide.

0 Kudos
Message 4 of 10
(3,211 Views)

When you bridge the devices you get a new virtual NIC device representing the bridge. If you had a specific IP configuration for the individual ports previously, you'll need to replicate that on the bridge device itself.

0 Kudos
Message 5 of 10
(3,208 Views)

Blue Cheese,

 

Thanks for your prompt response. I did not have any special configuration, as far as I know. Both NICs are set for DHCP and Automatic Private IP address. ipconfig /all tells me they have unique addresses.

0 Kudos
Message 6 of 10
(3,206 Views)

Hmm, then sorry, I'm not sure. It could be something like a firewall configuration that is preventing the bridge device from communicating or it could be something else. There's not a whole lot of new XP systems being deployed so I don't have too much recent experience with the quirks of such a setup. Windows Vista and later don't need this funky bridge mechanism to work properly.

 

You could try using Wireshark to take a packet capture while you have MAX open and see if you see discovery packets being sent out.

0 Kudos
Message 7 of 10
(3,204 Views)

Blue Cheese,

 

I'll have a look at the setting for the bridge; maybe I've missed something.

 

Re: Wireshark. Is there something specific I should look for? You mention 'discovery packets'; I assume they will be obvious to ID. Anything else?

0 Kudos
Message 8 of 10
(3,201 Views)

@jmevans wrote:

Blue Cheese,

 

I'll have a look at the setting for the bridge; maybe I've missed something.

 

Re: Wireshark. Is there something specific I should look for? You mention 'discovery packets'; I assume they will be obvious to ID. Anything else?


With recent versions of Wireshark, GigE Vision is decoded natively. Just use the filter "gvcp" to see them. If you do see them, see if you see both broadcast queries and unicast responses from the cameras. You can attach the trace here as well and I can take a look.

0 Kudos
Message 9 of 10
(3,199 Views)

Blue Cheese,

 

Well, it's amazing what can be done by just shotgunning stuff. I removed one of the NICs from the bridge, to see if it would reappear in MAX with the bridge still active. It did. I then added it back to the bridge and now both cameras appear and are accessible!

 

Thanks for your help.

0 Kudos
Message 10 of 10
(3,190 Views)