From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

Machine Vision

cancel
Showing results for 
Search instead for 
Did you mean: 

avi2 not working with queues

Hi, 

 

I have a problem with using the histogramcolour function and also the avi functions. I'm using these with producer consumer architecture where by i read each frame of the video using the avi read frame function and then queue this to the consumer and it works fine. however i tried to change the avi functions to the avi2 versions and this stopped the program working. i now get an error at the imaq histogramcolour function with a possible reason saying imaq vision: not an image. why would it work for the old version of avi functions but not the new ones?

 

does anyone know what the problem is? Ive attached the vi

 

Thanks

Labview 14.0, Labview 12.0
CLAD
Mechanical Engineering Student
Download All
0 Kudos
Message 1 of 22
(3,815 Views)

I test this 

it work

test this 

and  tell if it work for you or not 

0 Kudos
Message 2 of 22
(3,801 Views)

i cant open it because I'm using labview 14. I also can't update to labview 15 because I'm using a university pc. is there another way i could run it. what did you change? 

 

Thanks for the help 🙂 

Labview 14.0, Labview 12.0
CLAD
Mechanical Engineering Student
0 Kudos
Message 3 of 22
(3,783 Views)
0 Kudos
Message 4 of 22
(3,780 Views)

nope same error as before. I tried to run it with the avi file i have and also the image that was loaded of the balloon. would didnt work.

Labview 14.0, Labview 12.0
CLAD
Mechanical Engineering Student
0 Kudos
Message 5 of 22
(3,778 Views)
did you test this vi with labview example avi file like balloon?!
also check this link about the codec and if it not work yet you have to repair you vision toolkit
http://www.ni.com/tutorial/14466/en/
0 Kudos
Message 6 of 22
(3,773 Views)

i dont have access to the ballon avi file. in the national instruments folder at my university there is no vision folder and thus no avi example files

Labview 14.0, Labview 12.0
CLAD
Mechanical Engineering Student
0 Kudos
Message 7 of 22
(3,768 Views)

I just tried using a random avi file that i downloaded from the internet and the same problem occurs. Error - 1074396120

Labview 14.0, Labview 12.0
CLAD
Mechanical Engineering Student
0 Kudos
Message 8 of 22
(3,767 Views)

use these to test 

0 Kudos
Message 9 of 22
(3,761 Views)
0 Kudos
Message 10 of 22
(3,760 Views)